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Safety Information
Observe the following precautions to avoid fire or injury and prevent damage to this product or any
products connected to it.
Use this product only for its intended purpose as specified.
Use only the power adaptor specified for this product and certified for the country of use.

Ensure that the power source provides the power level supported by the power adaptor.
To avoid fire or shock hazard, observe all ratings and markings on the product and power supply and
ensure the product is properly grounded.
Do not connect or disconnect probes or test leads while they are connected to a voltage source. Connect
the probe reference lead to earth ground only.
Do not block the power cord; it must remain accessible to the user at all times.
Do not operate this product with covers or panels removed.
If you suspect that there is damage to this product, have it inspected by qualified service personnel. Do
not operate with suspected failures.
Do not operate in wet/damp conditions. Do not operate in an explosive atmosphere. Keep product
surfaces clean and dry. Provide proper ventilation for operation of product.
Only qualified Protocol Insight personnel or representatives should perform service procedures

P a g e |2

Product Overview
The Falcon series are the established industry standard with powerful protocol analyzer and exerciser
capabilities and unprecedented flexibility.
•

The Falcon G400B is a protocol analyzer that can capture x2 bi-directional links as a “sniffer”. It
supports up to MIPI M-PHY v4.1 HS-G4B, UniPro v1.8 and UFS3.1.

•

The Falcon G450B is identical to the G400B analyzer but is also a protocol exerciser that can generate
link traffic on a x2 bi-directional link while simultaneously capturing the response traffic from the DUT.
The Falcon G450B exerciser can execute the UniPro v1.61, UniPro v1.8, and JEDEC JESD224A
Compliance/Conformance Test Suites (CTS), and has preliminary support for UFS 3.1 CTS testing.

•

The Falcon G300B analyzer supports MIPI M-PHY v3.1 HS-G3, UniPro v1.61, and UFS2.1, and can be
upgraded to support HS-G4B and UFS3.1.

•

The Falcon G350B exerciser/analyzer is identical to the G300B analyzer but is also a protocol exerciser
that can execute the UniPro v1.61 and JEDEC JESD224A Compliance/Conformance Test Suites (CTS),
and can be upgraded to execute the UniPro v1.8 CTS with preliminary UFS3.1 CTS support.

The Raptor series are UFS and UniPro protocol analyzers with robust capabilities for debugging everyday
issues. This series is only capable of protocol analysis.
•

The Raptor M400 is a protocol analyzer that can capture x2 bi-directional links as a “sniffer”. It
supports up to MIPI M-PHY v4.1 HS-G4B, UniPro v1.8, and UFS3.1

•

The Raptor M300 analyzer supports MIPI M-PHY v3.1 HS-G3, UniPro v1.61 and UFS2.1, and can be
upgraded to support HS-G4B and UFS3.1.

Key Features
Smart Tune™ equalization
Capturing the signal from the DUT can be problematic when trace routing or the cabling to the test fixture
causes poor signal integrity or probing issues. Smart Tune™ equalization optimizes signal acquisition at
the analyzer to ensure error-free MPHY symbol capture.

Eye Monitor
Eye Monitor constructs an eye diagram of the link to determine link quality. Qualitative measurements
can be done on the eye diagram for jitter, noise, and eye opening.

Streaming capture
Streaming capture uses the full 40Gbs bandwidth of Thunderbolt3 to store link traffic directly to disk in
real time. This allows for virtually unlimited trace capture.
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Trace Validation™ (TV) analysis
Trace Validation uses state machine logic to analyze captured traces algorithmically without user
intervention. It analyzes bi-directional UniPro and UFS traffic, performing protocol sequence and timing
analysis and packet header and payload inspection.

Events view
Displays events on the bus in a unique time-aligned display, and includes fillers, Prepare, SYNC, Hibern8,
sleep, stall and other M-PHY level packets. Events view presents a complete picture of all events and
allows drill-down to the lowest level bytes.

Compliance (CTS) Testing (Falcon G350B/G450B only)
Test executive performs compliance verification of UFS 3.1/2.1 and conformance verification of UniPro
1.8/1.61 with Compliance/Conformance Test Suites (CTS). It executes a range of CTS test cases, analyzing
results using the Trace Validation engine and generating pass/fail and summary reports.

Stimulus for corner case and margin testing (Falcon G350B/G450B only)
Stimulus with full UniPro stack in HW allows creation of specific traffic on the link, offers extensive error
injection and is capable of full protocol emulation.

Test executive stress testing (Falcon G350B/G450B only)
Test executive stress testing executes hundreds of thousands of tests automatically. Stop after any
number of loops or No Result Test Cases.

Custom test case creation
Design custom tests to test corner cases or introduce errors for margin, stress, or error recovery testing.
Editors allow complex test creation, error injection, device control, and protocol sequence and packet
state machine construction for stimulus and Trace Validation.

Instrument Description
The Falcon G300/G400 series and Raptor M Series consist of an instrument and a power brick. A controller
PC with Thunderbolt 3 connectivity is required and is not included. Other components required for
instrument operation that are not supplied include 50 ohm matched-length cables and power splitters, or
a solder-down probe. See ACCESSORIES for more information.
The Falcon G300/G400 and Raptor M Series front panel connectors are used to probe links at the Tx, Rx,
or the midpoint. The “Sublink 0 Analyzer” connectors are used to capture and analyze one direction of
link traffic while the “Sublink 1 Analyzer” connectors capture the other direction of link traffic.
The Falcon G350/G450 “Sublink 1 Tx Exerciser” front panel connectors generate traffic on the link and the
“Sublink 0 Exerciser/Analyzer” connectors are used to capture and analyze the response traffic. When
using the instrument as an exerciser the “Sublink 1 Analyzer” connectors are not used.
The connectors on the front panel are labeled from the instrument perspective, not the DUT perspective.
So, the connectors labeled Rx are for capturing signals from the bus and connectors labeled Tx are for
generating traffic on the bus.
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Analyzer front panel - Falcon G300B/G400B and Raptor M300/M400

Analyzer front panel - Falcon G300/G400

Front panel connectors:
A.
B.
C.
D.
G.
H.
I.
J.
K.

Connect the TxDN and TxDP from device M-Tx lane 1 here.
Connect the TxDN and TxDP from device M-Tx lane 0 here.
Connect the RxDN and RxDP from device M-Rx lane 1 here.
Connect the RxDN and RxDP from device M-Rx lane 0 here.
Generates a UFS reference clock on 19.2, 26, 38.4 and 52 MHz at 1.2V.
Generates a 1.2V reset signal .
Trigger in to the analyzer.
Trigger out from the analyzer.
Ground

Connectors are SMP male for Falcon G300B/G400B and Raptor M300/M400 and SMA female for
Falcon G300/400.
NOTE: use of connector savers on the instument front panel SMP connectors is strongly
recommended to avoid damage to the connectors. See THIRD PARTY ACCESSORIES for recomended
connector saver accessories.
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Exerciser/Analyzer front panel - Falcon G350B/G450B

Exerciser/Analyzer front panel - Falcon G350/G450

Front panel connectors:
A. Connect the TxDN and TxDP from device M-Tx lane 1 here.
B. Connect the TxDN and TxDP from device M-Tx lane 0 here.
C. Connect the RxDN and RxDP from device M-Rx lane 1 here. This is used for the analyzer only,
for the Exerciser these connectors are not used.
D. Connect the RxDN and RxDP from device M-Rx lane 0 here. This is used for the analyzer only,
for the Exerciser these connectors are not used.
E. Connect to the RxDN and RxDP from device M-Rx lane 1 here. This is used for the exerciser
only, for the analyzer these connectors are not used.
F. Connect to the RxDN and RxDP from device M-Rx lane 0 here. This is used for the exerciser
only, for the analyzer these connectors are not used.
G. Generates a UFS reference clock on 19.2, 26, 38.4 and 52 MHz at 1.2V.
H. Generates a 1.2V reset signal.
I. Trigger in to the analyzer.
J. Trigger out from the analyzer.
K. Ground
Connectors are SMP male for Falcon G350B/G450B and SMA female for Falcon G350/450.
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NOTE: use of connector savers on the instument front panel SMP connectors is strongly
recommended to avoid damage to the connectors. See THIRD PARTY ACCESSORIES for recomended
connector saver accessories.

Side panels
Right - Falcon G300B/G400B and Raptor M300/M400

The Thunderbolt 3 connectors, which are USB Type-C connectors, do not support USB3.0.

Right - Falcon G300/G400 Series

The Thunderbolt 3 connectors, which are USB Type-C connectors, do not support USB3.0.
The power connector type is IEC, center pin is +12V.
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Rear - Falcon G300B/G400B and Raptor M300/M40

The power connector type is IEC, center pin is +12V.

Licenses available
Full
Instruments shipped after December 8, 2017 utilize an embedded HW key and no SW
license is required. This key is configured at the factory, floats with the instrument and
works with any PC.
Instruments manufactured before December 8, 2017 require a SW license key to enable
the appropriate capabilities, which is available from support@protocolinsight.com. SW
license keys are node-locked to the controller PC and are not transferable.

Offline
If the application software is launched with no SW or HW key present, the application will
enable Offline-only capabilities.
When Offline the user can open previously saved trace files to analyze the trace. The
analysis windows available in Offline include the list, protocol decode and events
windows. Offline-only does not enable the Trace Validation Results window or Trace
Validation Editor.

Offline Viewer with Trace Validation and TV Editor
This license is a SW license available from support@protocolinsight.com. SW license keys
are node-locked to a PC and are not transferable. Offline with TV and TV Editor operates
like the standard Offline but enables the Trace Validation Results window and TV Editor
to create custom TV tests.

Offline Viewer with Trace Validation and all Editors
This license is a SW license available from support@protocolinsight.com. SW license keys
are node-locked to a PC and are not transferable. Offline with TV and all Editors operates
like the standard Offline but enables the Trace Validation Results window plus all Editors,
including the TV, advanced trigger and stimulus Editor.
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Options and Upgrades
Contact your local representative for list of available instrument SW/FW upgrades.

Accessories
FG4PSD2B
FG4PSD3
FG4PSD2
FSWOVTVE
FSWOVTVEDITORS
EnhanceConn
FAECase

x2 Bundle - 2 Pigtail cables with power connectors and probe tips
Multi-Lead Pod option - Multi-Lead Pod, Carlisle cables, SSMP-to-SMP cable pairs
x2 Bundle - Multi-Lead Pod, Carlisle cables, SSMP-to-SMA cable pairs, probe tips
Offline Viewer with Trace Validation and TV Editor
Offline Viewer with Trace Validation and all Editors
Enhanced connectivity kit –TB3 6ft/2m 40Gbps active cable and retention device
Field carry bag

Third party accessories
The following accessories are available from third party suppliers:
• Connector savers: Adapter Coaxial Connector SMP Plug, Male Pin To SMP Jack, Female 50 Ohm
Amphenol SV Microwave 1112-4012 CONN ADAPT PLUG-JACK SMP 50 OHM ADAPTER COAXIAL
CONNECTOR or equivalent
• SMP-to-SMA cables: ≥18GHz, ≤225mm/9” length, phase-matched
Centric RF C572-086-09B or equivalent
• SMA to SMA cables: ≥18GHz, ≤225mm/9” length, phase-matched
Centric RF C581-086-09 or equivalent
• Power splitter, DC-18 GHz
Mini-Circuits ZFRSC-183-S+ or equivalent

Probing Configuration Options
Depending on the application, analyzer or exerciser/analyzer, there are several different recommended
probing options for connecting to the DUT provided below.

Analyzer
Solder-down
x1 link shown
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Splitters
Off-the-shelf power splitters such as the Mini-Circuits DC-18 GHz ZFRSC-183-S+ can be used with standard
SMP to SMA cables of ≥18GHz and maximum of 12 inches in length. Each link requires four power splitters
and 12 cables as shown in this x1 link example:
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Breakout DUT
50% split = 16.7 ohms resistor

Interposer
50% split = 16.7 ohms resistor

Exerciser
Direct connection

P a g e | 11

Setup and Operation
General Instrument Configuration
All general instrument, device and user preference settings can be accessed from either the Settings menu
or by clicking
settings.

from the toolbar. See SETTINGS WINDOW for information on how to change general

Analyzer Configuration
To configure for general debug analysis or for Trace Validation follow these steps:

Step 1: Connect the probes
Note: the labels on the analyzer front panel are from the instrument perspective.
1.
2.
3.
4.
5.
6.
7.
8.

Connect the Sublink 0 Rx_1N to TxDN from the device M-Tx lane 1.
Connect the Sublink 0 Rx_1P to TxDP from the device M-Tx lane 1.
Connect the Sublink 0 Rx_0N to TxDN from the device M-Tx lane 0.
Connect the Sublink 0 Rx_0P to TxDP from the device M-Tx lane 0.
Connect the Sublink 1 Rx_1N to RxDN from the device M-Rx lane 1.
Connect the Sublink 1 Rx_1P to RxDP from the device M-Rx lane 1.
Connect the Sublink 1 Rx_0N to RxDN from the device M-Rx lane 0.
Connect the Sublink 1 Rx_0P to RxDP from the device M-Rx lane 0.

See PROBING CONFIGURATION OPTIONS for more information on how to connect to the DUT.

Step 2: Configure the analyzer
1.
2.
3.
4.

Select Analyzer mode on the toolbar (G350B/G450B only)
Under Instrument Configuration select the desired memory Capture Options.
Under Instrument Configuration set the Connected Link Width for each direction to x1 or x2.
Under User Preferences determine if UFS packets are decoded when the trace capture is
complete.

Step 3: Capture the trace
1. Configure the trigger from the Tools menu if desired.
2. Press Analyzer Connect, then Start, and capture the trace.

Step 4: Configure and run Trace Validation tests
1. Go to the TV Configuration window.
2. Select which Trace Validation Tests to run.
3. Press the Start button and watch the TV Results windows fill with Pass, Fail, Warning, or Info
results.

Exerciser Configuration (G350B/G450B only)
To configure for compliance/conformance (CTS) testing, corner case, margin or automated stress testing
follow these steps:
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Step 1: Connect probes
Note: the labels on the analyzer front panel are from the instrument perspective.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

Connect the Sublink 0 Rx_1N to TxDN from the device M-Tx lane 1.
Connect the Sublink 0 Rx_1P to TxDP from the device M-Tx lane 1.
Connect the Sublink 0 Rx_0N to TxDN from the device M-Tx lane 0.
Connect the Sublink 0 Rx_0P to TxDP from the device M-Tx lane 0.
Connect the Sublink 1 Tx_1N to RxDN from the device M-Rx lane 1.
Connect the Sublink 1 Tx_1P to RxDP from the device M-Rx lane 1.
Connect the Sublink 1 Tx_0N to RxDN from the device M-Rx lane 0.
Connect the Sublink 1 Tx_0P to RxDP from the device M-Rx lane 0.
Connect the UFS RST_N to the DUT reset signal
If desired, connect the UFS REF CLK to the DUT ref clock input.

See PROBING CONFIGURATION OPTIONS for more information on how to connect to the DUT.

Step 2: Configure the exerciser/analyzer
1.
2.
3.
4.

Select Exerciser + Analyzer or CTS mode on the toolbar
Under Instrument Configuration select the desired memory Capture Options.
Under Instrument Configuration set the Connected Link Width for each direction to x1 or x2.
Under User Preferences determine if UFS packets are decoded when the trace capture is
complete.

Step 3: Configure Device Under Test
1. Default device values are pre-set for the DUT in the Device Configuration tab of the Settings
window. Update the Device Configuration values for any settings that are unique to your device,
see APPENDIX D: DISCOVERING UFS DEVICE CONFIGURATION VALUES for more information.
2. A UniPro and/or UFS link connection between the exerciser and DUT is required for the exerciser
to perform compliance/conformance (CTS) testing, corner case, margin or automated stress
testing. Press the “Boot” button in the tool bar to boot the DUT. If UniPro is the Default Protocol
in Settings->User Preferences->Display Preferences or is the selected Protocol in the Device
Control section of the Configuration windows pressing “Boot” will initiate the Link Startup
Sequence. If UFS is the selected protocol a boot will be completed including UniPro LSS and UFS.

Step 4: Configure tests
1. Go to the CTS Configuration or Exerciser & TV Configuration window.
2. Select which Speeds, Link Widths and other device configurations to test. If testing UFS the
appropriate LUNs must be selected.
3. Select which test Categories and Tests to run.

Step 5: Configure stress testing
Test Run Order controls the order in which tests are executed.
1. Loop Order: loop order specifies the nested order of test execution. Tests will be run from the
bottom up, with all tests in each loop executed before the next higher loop is begun. So, if the
Loop Order is Speeds, Link Widths, Tests then all Tests will be completed for a Link Width before
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being executed for the next Link Width, etc. The loop order can be adjusted by dragging categories
up or down in the Loop Order box.
2. Ascending, Descending, Random Seed: this specifies which order the tests are executed within
the Loop. If Random Seed is selected a value can be entered to generate a random but
reproducible test order based on the seed value.

Step 6: Configure Run Control
Test Run Control specifies the number of iterations of the test configuration to run, dictated by Test Run
Order. Test execution will stop after the specified Number of Loops (outer loops on Test Run Control) or
No Result Test Cases have occurred.
The user can specify the number of test configuration loops to run OR the number of No Result Test Cases
to allow before terminating the test run. When Number of No Result Test Cases field is blank or 0, tests
are run for the given number of loops. If values are provided for both conditions, then tests are run until
any ONE of the conditions is met.

Step 7: Run the configured tests
Press the Start or Start CTS button to run the configured tests, and watch the Results windows fill with
Pass, Fail, Warning, or Info results.

Running concurrent instances of the application software
Two instances of the application software can be used concurrently, however only one instance of the
application can communicate with the analyzer hardware at a time. If you attempt to start more than
two instances of the application software concurrently you will see a message box informing you that only
two concurrent instances are supported.
When a second instance is started it will show "OFFLINE" in the title bar and its Connect button will be
disabled. If you close the first instance, which has the Connect button enabled, the second instance
remains an OFFLINE instance and to Connect to hardware you will need to start another instance to enable
the Connect button.
You can also start the application software by double-clicking on an *.pitx configuration file. If an
application is already running, it will start a second instance which will load the configuration file.
You can load the same *.pitx file in two instances and, for example, view different areas of the trace sideby-side in the two instances.

P a g e | 14

Navigating the User Interface
Tool Bar

The tool bar allows selection of analysis view modes and run control for the test executive and the analyzer
and status update information:
Modes (1) allow the user to select a set of three pre-defined windows based on the instrument
configuration and type of analysis being conducted (see WINDOWS below).
Start (2) initiates Trace Validation or test case execution for the selected tests.
Instrument status/settings and control (3) displays the status of the instrument hardware and software
connection, various settings and starts and stops trace capture.
Instrument status:
Red = software application is not connected to instrument hardware and the software is offline.
Yellow = software application is connected to the instrument hardware and the software is online.
Green = the instrument is connected and capturing traces.
Clicking on the Trigger or Filter buttons will open the Trigger Setup and Filter windows.
By clicking Connect the software will initiate connection with the hardware and go online.
Clicking Start or Stop will begin or end a trace capture.
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Settings (3) configures user preferences,
the instrument hardware, and the device
under test (G350B/G450B only). Settings can
also be accessed from the menu.
The DUT status/control (4) indicators show
the status of the DUT. One indicator is used
for each direction of a link, so a x1 link will
show two indicators and a x2 link will have
four indicators. Indicator colors are as
follows: grey = not connected, yellow =
device operating at PWM speeds, green =
device operating at HS speeds. Clicking Boot
will initiate a UniPro or UFS boot of the DUT.
The application status bar (5) indicates
progress during common activities such as
file open/save and test case execution.
Clicking the blue info icon on the right side
will open the APPLICATION STATUS window.
Pressing cancel will stop any background
processes being performed, such as calculating Traffic Overview or Events, and can cancel test executive
and trace validation execution.
Custom toolbars can be added to the main application, see USER TOOLBAR TAB for more information.
Custom toolbars are added to the row below the factory default toolbar:

Windows
Selection of one of three display modes (1 above), Analyzer, CTS, or Exerciser + Analyzer, will activate a
set of pre-defined windows:
Analyzer mode will open the Trace Validation Results and Traffic Overview windows, UniPro and
UFS Packet List and Events windows, TV Configuration, Packet Decode and Data View. Instrument
Status is positioned on the right side as a tab, and Simple Packet Search is a tab on the left side.
CTS mode opens the TV Results and Traffic Overview windows, the Packet List and Events
windows, and Packet Decode and Data View. It also opens the CTS Configuration window to set
up and run CTS test cases. Available for the G350B/G450B only.
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Exerciser + Analyzer mode opens the TV Results and Traffic Overview windows, and the UniPro
and UFS Packet List and Events windows, Packet Decode and Data View. It also opens the Stimulus
Results and Exerciser & TV Configuration windows. The Exerciser & TV Configuration window
provides access to all configuration settings and the permits the running all tests, including
differing stimulus and Trace Validation tests, in one single test run. This can result in the creation
of one test result trace file with many types of link traffic. Available for the G350B/G450B only.

Figure 1: Exerciser + Analyzer window layout

All windows are dock-able inside or outside of the application framework, using standard docking
paradigms. Windows can be restored to the default mode configurations by selecting View->Restore
Default Layout from the main menu.

Configuration window – Analyzer mode
Device Control
Protocol: Selecting either UniPro or UFS Protocol determines which tests are listed in the Tests
section below. This also dictates the action of the Boot button on the toolbar.
Validation Settings
Debug Enabled: turns on Trace Validation test debugging. Messages that are generated by the
Trace Validation test are output to the Trace Validation Results window to help users track
progress in the Trace Validation analysis. See Debug under INTERPRETING TRACE VALIDATION
RESULTS for more information.
Tests
Select the test cases to be executed. The following test categories are available for execution in Analyzer
mode:
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UFS CTS Test Cases: The Test Cases in this category verify compliance to the UFS CTS. A Trace
Validation result of “Pass” indicates the DUT meets the CTS Test Case criteria. In Analyzer mode
these tests are run as Trace Validation tests against existing traces.
UFS Debug: This category contains general UFS debug tests.
UniPro CTS Test Cases: The Test Cases in this category test the DUT for compliance to the UniPro
CTS. A Trace Validation result of “Pass” indicates the DUT meets the CTS Test Case criteria. In
Analyzer mode these tests are run as Trace Validation tests against existing traces.
UniPro Debug: This category contains debug test cases to check UniPro behavior. For example, to
verify that the Link Startup Sequence ran correctly.
Search TVs: These Trace Validation tests can be used to search a trace for specific conditions. The
application software library includes three search TVs, “Find UniPro Error Packets“, “Find UFS
Error Packets” and “Find Protocol Insight CTS Markers”.
Advanced Trigger Offline TVs: Advanced Triggers that have been defined with Test Editor can be
run against any previously captured trace to find trigger events in existing traces, or to test newly
constructed advanced triggers. If no Advanced Triggers have been defined this category won’t
appear.
Custom Tests: Custom test directories are displayed in italics at the bottom of the list; with Trace
Validation custom tests shown in Analyzer mode. If no custom test cases exist in a directory the
directory will not be displayed. The tests listed can be refreshed from the File menu as new custom
test case are created.

Configuration window – CTS mode
Available for the G350B/G450B only.
Device Control
Initiate Reboot Device Up Every Run: If this box is checked, the reset line (see line 9 of STEP 1:
CONNECT PROBES) is asserted and a UFS boot and/or UniPro Link Startup Sequence is executed
before every test case. This should be used for early testing to verify the tests work with a known
device state, once this has been verified it is recommended to deselect this option.
Protocol: Depending on this selection, the test list in the Tests section of the Configuration
windows is filtered for UniPro or UFS tests and the Configured LUNs section is hidden or displayed
for device and run control choices.
This selection also controls the action of the Boot button in the tool bar. The Boot button will
either boot the device through LSS if UniPro is selected, or to UFS if UFS is selected.
The primary (default) protocol for this selection can be set in Settings->User Preferences->Display
Preferences
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Test Run Order
Control the order in which tests are executed. Run
order is specified by Loop Order in Ascending,
Descending, or Random Seed order. See STEP 5:
CONFIGURE STRESS TESTING for more information.
Test Run Control
Specify the number of test cycles of the test
configuration to run. Test execution will stop after the
specified number of full test loops (outer loops on Test
Run Control) or No Result Test Cases have occurred. See
STEP 6: CONFIGURE RUN CONTROL for more information.
Transmission Mode
Controls Auto/NonAuto power modes during Test Run
operation.
Scrambling
Enable or disable data scrambling during Test Run
operation.
Rate Series
Enable or disable Rate Series A and/or B.
Traffic Class
Only TC0 is supported during Test Run operation.
Configured LUN
If UFS Protocol is selected under Device Control in the Configuration windows or as the Primary
(default) Protocol in Settings->User Preferences->Display Preferences, this section will be visible
and is used to choose the Configured LUNs to control and test with test executive Run Control.
All UFS tests in the Configuration windows are associated with a LUN. The tests that have a LUN
value of 255 correspond to the NONE (LU agnostic) selection in the Configured LUN selector. For
requests that do not target a specific LUN (e.g. a Query Request with the Read Descriptor Opcode)
the NONE LUN is used.
The NONE (LU Agnostic) LU is specific to the Protocol Insight test Configuration windows, they
aren’t mentioned in the UFS spec. Since every test is associated with a LU this is how to define a
test that is LU agnostic.
Speed
Configure the speeds to be tested.
Link Width
Configure the link widths to be tested. UniPro and UFS widths up to x2 are supported.
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Validation Settings
Debug Enabled: turns on Trace Validation test debugging. Messages that are generated by the
Trace Validation test are output to the Trace Validation Results window to help users track
progress in the Trace Validation analysis. See Debug under INTERPRETING TRACE VALIDATION
RESULTS for more information.
Tests
Select the CTS test cases to be executed.

Configuration window - Exerciser + Analyzer mode
Available for the G350B/G450B only.
This configuration window replicates all the functionality of the CONFIGURATION WINDOW – CTS MODE, with
the following additions to the Tests section:
Tests
The list of available tests can be filtered:
Selecting “All” will display all tests in the list, including Stim, TV and CTS tests. The type of test
is identified by an icon as either a legacy Stimulus Builder test with a red
test with an orange
Validation

, a Trace Validation test

, a Stimulus Test Editor

, or a test containing both Stimulus and Trace

.

Selecting All permits the running of all tests, including differing Stimulus and Trace Validation
tests, in one single test run, resulting in the creation of one trace result file with many types of
link traffic and analysis.
Selecting “TV” will display only Trace Validation tests.
Selecting “Stim” displays only stimulus tests.
Filter Linked Tests: Checking the “Filter Linked Tests” box when All is selected will filter the list
and only display those tests that include both a Stim and associated TV test. Tooltips identify the
Stim test linked to each TV test listed.
Depending on the display mode selected the following test categories and tests may be available for
execution in the Tests section:
UFS CTS Test Cases: The Test Cases in this category test the DUT for compliance to the UFS CTS.
Execution of the linked Stimulus with a Trace Validation result of “Pass” indicates the DUT meets
the CTS Test Case criteria.
UFS Debug: This category contains general UFS debug tests.
UniPro CTS Test Cases: The Test Cases in this category test the DUT for compliance to the UniPro
CTS. Execution of the linked Stimulus with a Trace Validation result of “Pass” indicates the DUT
meets the CTS Test Case criteria.
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UniPro Debug: This category contains general UniPro debug test cases to check UniPro behavior.
For example, to verify that the Link Startup Sequence ran correctly.
Search TVs: These Trace Validation tests can be used to search a trace for specific conditions. The
application software library includes three search TVs, “Find UniPro Error Packets“, “Find UFS
Error Packets” and “Find Protocol Insight CTS Markers”.
Advanced Trigger Offline TVs: Advanced Triggers that have been defined with Test Editor can be
run against any previously captured trace to find trigger events in existing traces, or to test newly
constructed advanced triggers. If no Advanced Triggers have been defined this category won’t
appear.
Custom Tests: Custom test directories are displayed in italics at the bottom of the list; if no custom
test cases exist in a directory the directory will not be displayed. Depending on the display mode
selected, Stimulus and/or Trace Validation custom tests will be shown. The tests listed can be
refreshed from the File menu as new custom test case are created.

UniPro and UFS Packet List windows
The Packet List windows display all packets in a trace. If Trace Validation is used, clicking on a result in the
Trace Validation Results window will position the cursor in the Packet List window on the packet of
interest in the test sequence.
The information displayed in the Packet List can be changed by right-clicking in the column header bar
and selecting different columns from the list available.

Correlated views: The Packet List views can be locked so that the active cursor correlates to the same
packet in each view. Clicking the Lock icon in the upper right corner of a List view will lock all windows,
and a “Correlated” bookmark will identify the active cursor in each window view.
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Color Coded packets: Common packet types in the list window are color-coded the same, for example, all
End_of_Burst, PACP_SET_cnf or PACP_GET_cnf packets are of the same color. Color selections can be
changed from the menu from Setting->Packet Display or by clicking the Settings icon on the toolbar.
All error packets are highlighted in red. For more info about error packets see “What is the difference
between Symbol Errors in the Instrument Status window and red error packets in the UniPro and UFS
Packet listing windows?” in the app note PDF “App Note Tech Support FAQs”.
Bookmarks can be added to any packet in a Packet List or Event view window by right-clicking and
selecting Add Bookmark. By right-clicking and selecting Edit Bookmark an existing bookmark can be
renamed or given a different color.
Bookmarks can be used to add comments to traces in the Comments field.
Comment are tied to a bookmark, which can be locked to a specific packet
so it can’t be moved. All comments in a trace can be viewed in the
BOOKMARK LIST WINDOW; if the comment has multiple lines the full
comment is displayed in the tooltip when hovering over the comment:
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Hovering over a bookmark will display a tooltip indicating timestamp and delta time to
other bookmarks. If Zero Time Stamp Here is selected, all timestamps are recalculated
from the selected packet, with negative timestamps before and positive timestamps
after that packet. Selecting Restore Original Time Stamp will reset the timestamps to the original values.
Navigating a Packet List window can be
accomplished in several ways activated by rightclicking anywhere in a Packet List or Event
window:
Go To permits navigation to Start of Trace, End of
Trace, last packet or bookmarks.
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UniPro Events window
The UniPro Events window contains five panes, the Overview, Detail, Link, Lane and Sample panes, that
allow drill-down from the full trace to the lowest level packet information:

Overview pane
The Overview pane, in the blue box, consist of two scatter charts (one for each direction) that represent
each packet in the trace with its time position as a dot. Since there are usually more packets in a trace
than horizontal pixels in the view, each dot in the view will usually represent multiple packets.

The numbers along the X-axis represent time since the beginning of the trace and each row along the Yaxis represents a set of packet types.
The top row is the Speed row and is always present when any packet is present. It is the only multi-color
row, changing color when the speed changes. The speed colors are:
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PWM-G0 x1, PWM-G0 x2, PWM-G1 x1, PWM-G1 x2

PWM-G2 x1, PWM-G2 x2

PWM-G3 x1, PWM-G3 x2

PWM-G4 x1, PWM-G4 x2

PWM-G5 x1, PWM-G5 x2

PWM-G6 x1, PWM-G6 x2

PWM-G7 x1, PWM-G7 x2

HS-G1A x1, HS-G1A x2, HS-G1B x1, HS-G1B x2

HS-G2A x1, HS-G2A x2, HS-G2B x1, HS-G2B x2

HS-G3A x1, HS-G3A x2, HS-G3B x1, HS-G3B x2

HS-G4A x1, HS-G4A x2, HS-G4B x1, HS-G4B x2

Unknown speed
The remaining rows are presented in this order:

DataFrame_BadTC, AFCBadTC

P a g e | 25

NAC

DataFrame_TC0, DataFrame_TC1

PACP_PWR_req,
PACP_PWR_cnf,
PACP_CAP_ind,
PACP_CAP_EXT1_ind,
PACP_EPR_ind,
PACP_TEST_MODE_req,
PACP_GET_req,
PACP_GET_cnf,
PACP_SET_req,
PACP_SET_cnf,
PACP_TEST_DATA_0, PACP_TEST_DATA_1, PACP_TEST_DATA_2, PACP_TEST_DATA_3

AFC_TC0, AFC_TC1

TRG_UPR0, TRG_UPR1. TRG_UPR2

SOB, EOB, FLR, SKIP, PREPARE, SYNC, HIBERN8, BURST, SLEEP, STALL, LINE_RESET, LINE_CFG

End of trace is marked with a white dot with a red border. There can be multiple End_Of_Trace
events.
In the Overview pane there are 3 special markers, B, E, and C, which are drawn above each direction chart.
The orange color of the B and E markers correspond to the range in the orange Detail pane (see red arrows
below) while the C marker is always light blue. Hover over a marker to see its long name and time:
•
•
•

B – Begin – Where the Detail pane Begins in the Overview pane
E – End – Where the Detail pane Ends in the Overview pane
C – Center – The location of the packet that is at the Center in all Event views

Bookmarks (e.g. B1 and B2) are drawn below each direction and tie to the same bookmarked packets in
the other display windows. If additional bookmarks are added by the user, they will also be displayed in
all Events panes. If you hover over a bookmark it will display its time and the time to other markers.
By clicking/dragging in the Overview pane or by moving the B/E markers or by selecting a button in the
Zoom Tool Bar on the left the range that is displayed in the Detail pane below can be changed. The C
marker moves to the center of the B/E range when you change the B/E range with any method:

P a g e | 26

Detail pane
The Detail pane is similar in appearance to the Overview pane, but it displays only the range currently
selected in the Overview pane. It uses the same colors and row arrangement as the Overview pane. A
dot typically indicates multiple packets of the type for the row, but you can zoom in to a point where a
dot represents a single packet.

You can change the range that is displayed in the Link and Lanes panes, which are the panes below the
Detail pane, by clicking/dragging in the Detail pane.
In the Detail pane there are 3 special markers, LB, LE and C. The LB/LE/C markers are not moveable. The
yellow color of the LB and LE markers correspond to the range in the yellow Link pane below, while the C
marker is always light blue. Hover over a marker to see its long name and time:
•
•
•

LB – Link Begin – Where the Link pane Begins in the Detail pane
LE – Link End – Where the Link pane Ends in the Detail pane
C – Center – The location of the packet that is at the Center in all Event views

The range of packets that are displayed in the Link pane below is indicated by the yellow LB and LE markers
and with an area of shading in the Detail pane.
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Link pane
The Link pane creates an intermediate view between the Overview and Detail scatter charts and the bytedetailed raw Lane and Sample panes.

In the Link pane the X-axis is a modified time scale. A packet time may be so small in comparison to a
Sleep that a true time scale for the packet would be less than a pixel in width, and the packet “rectangles”
appear as a line with a minimum width. Events are shown on a separate row from Packets. Where
possible, packets are grouped together to make a single rectangle. The tool tip for the rectangle shows
the packets and time that the rectangle represents.
In the Link pane there are 3 special markers, LB, LE and C. The LB/LE/C markers are not moveable. The
green color of the LB and LE markers correspond to the green Lane pane below, while the C marker is
always light blue. Hover over a marker to see its long name and time:
•
•
•

LB – Link Begin – Where the Lane pane Begins in the Link pane
LE – Link End – Where the Lane pane Ends in the Link pane
C – Center – The location of the packet that is at the Center in all Event views

The range of packets that are displayed in the Lane pane are indicated by the green LB and LE markers.
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Lane pane
The Lane pane shows byte level detail for about 200 packets around the Center marker (fewer packets
are displayed when the packets contain a lot of data). The X-axis is based only on the width of the
displayed bytes, it is not time-based and the only time component is the displayed time.
The higher level panes in Events (Overview, Detail, and Link) display decoded packet data from the UniPro
Packet List window. In contrast the Lane pane is built from the raw trace data.
The default Lane display interleaves the packets from the two lanes to show their time order. The X-axis
is based only on the width of the displayed bytes, it is not time-based, and the only time component is the
displayed time:
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Selecting the “Compress” button causes the display to redraw with no interleaving, and the “Compress”
button becomes “Interleave”:

An analyzer sample is 64 bits and may contain a time stamp and status info or a delta time stamp, status
info and 4 data bytes. Each delta time is added to the previous time to get the present time. The "State
0" and "State 1" rows indicate where full time stamps are in the trace. Hovering the cursor over a packet
of interest could therefore provide the following information on that packet:
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One Hot is present for K-Code bytes. It is the One Hot equivalent for the K-Code as defined in the spec.
Hex is the Hex value of the byte. K-Codes have both a One Hot and Hex encoding.
Sample The Sample Number is calculated in the Packet List View from binary trace data.
Absolute Is the Index in the UniPro Packet List that corresponds to the first two bytes in the sample. Most
bytes do not correspond to the first two bytes of a packet, for example the data bytes in a data
packet. These bytes have an Absolute of -1.
Valid Is the Valid status bits in the sample. They indicate the lanes where the 4 data bytes occurred. 4 in
lane 0, 4 in lane 1, two in each lane, two in one lane and a repeat count. The lanes the bytes are in can be
seen by the row where they are drawn. Repeat counts are drawn with a gray background.
Packet Time This is the time the packet starts in the UniPro Packet List and is equal to the time from full
time stamps and delta times.
Packet Time[0] Packet Time[1] Sometimes a packet begins in the second two bytes in a sample. Then
the time of the second packet is computed based on link speed.
Sample Time Is displayed when there are two Packet Times and is the time from the time stamps and
delta times in the samples.
If you hover across a row of data bytes you will see the Sample number increment. You may see a case
where a Sample number has been skipped between adjacent samples. This occurs when a time stamp
carries the same status info as the previous sample. There is no change in the lane state so nothing
appears in the Packet List for this sample.

P a g e | 31

Sample pane
The Sample pane shows byte level detail for the first 2 billion samples. The X-axis is based only on the
width of the displayed bytes, it is not time-based, and the only time component is the displayed time. The
packets in the two lanes are interleaved to show their Packet Index order.
The higher level panes in Events (Overview, Detail, and Link) display decoded packet data from the UniPro
Packet List window. In contrast the Sample pane is built from the raw trace data.

UFS Events window
The UFS Events panes are very similar to the UniPro Events panes. See UNIPRO EVENTS WINDOW for more
information. An important difference is that in UFS Events, each row represents a single packet type.
There are many possible packet types in UFS but in practice a trace tends to contain a subset of all the
possible packets that could be displayed. By dragging the blue bar at the bottom of the Detail pane the
scatter chart height can be increased to display more packet types.

The Detail pane is a zoomed view of the Overview chart that works just like the UniPro Events pane:
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This chart is sized larger because packet level details will be more important to users in this view.
In both the Overview and Detail panes the packet colors are the same as in the UFS Packet List window
and can be changed from the Settings menu:
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The Link panes are similar to the Link panes in UniPro Events. The important difference is that rather than
having an Events time row, they have either a Request or Response packet row, depending on direction:
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Packet Decode window
To display the protocol decode of a packet of interest in the Packet
Decode window, click on the packet in the appropriate Results
window or in a Packet List window. Hovering over a bit displays
additional decode information. Selecting 8, 16, or 32 defines the
bit width of the display.

Data View window
The Data View window displays the entire packet, including header
and payload for a selected packet. While the first 160 bytes of data
are fully decoded in the Packet Decode window, the remainder of
the packet payload is displayed in the Data View window only. Up
to 16 bytes can be displayed per line.
By right-clicking anywhere in the Data View window the user can
choose from several options to copy the data for pasting into other
applications.

Trace Validation Results window
Since CTS test cases use the Trace Validation engine
for protocol sequence and packet inspection, the
Trace Validation Results window is used in the
Analyzer, CTS and Exerciser + Analyzer modes to
display test or analysis results.
The TV Results window allows extensive quantitative
analysis of results data. Results can be grouped and
summarized, sorted, and filtered by any header
column. To turn on or off a column, right click in the
column header area.
Key words can be searched from the Search bar.
To group and summarize, click on any column header
and drag into the Test Results field. This will
summarize the results with an item count of occurrences.
Clicking on a TV Results message in the Results window will center that packet in the Packet List and Packet
Decode windows for further analysis.
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Traffic Overview window
Traffic Overview offers a summary of all packets found in the
trace. Any packet can be found by selecting that packet type in
the Traffic Overview window, clicking on either Host, Device or
Total, and clicking the up or down buttons to go to the next or
previous packets, or <| and |> to go to the first or last packets.

Stimulus Results window
The Stimulus Results window provides success/fail information
on the stimulus test cases executed. This window does not
display analysis results but only whether the stimulus test ran
successfully. Information in this window is not saved with File>Save Configuration or File->Save Configuration/Analyzer
Capture.

Message Console
Messages generated by the NLog debug logging tool
are automatically sent to the Message Console. These
are the same messages that are stored to the NLog
default log file at C:\Users\[user name]\AppData\
Local\Protocol_Insight\Falcon\Temp\logs\ logfile.txt.
Messages output from Stimulus Editor can also display
in the Message Console if implemented by the user.
The NLog messages can be disabled by unchecking
"Show Log Messages".

Simple Packet Search window
Simple Packet Search will search forwards or backwards on any sublink for any packet type, packet header
or payload value. A gated search range can be created by positioning bookmarks in the trace and using
the From dropdown under Search Options.
Select any active packet from the list in “Select Event for Search from this List” and use the Search Options
to navigate to packets that meet the search criteria. Note: until Traffic Summary
calculation is completed Simple Packet Search cannot be used since the available
packets will not be populated in the search list.
Double-clicking on the packet type of interest will bring up the Packet Editor (the
same used for Simple Trigger) to edit the header or payload values to search for.
These packet values can be saved as Favorite Packets for later re-use with either
Simple Packet Search or Simple Trigger.

Bookmark List window
The Bookmark List window will display all bookmarks in the trace, with the
timestamp, delta time to every other bookmark, and comments. Right clicking
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within the list will enable navigation to any bookmark in the trace. The Bookmark List window can only be
accessed from Menu->View->Bookmark List.

Trigger Setup window
The Trigger Setup window is accessed from the Tools menu. The
Choose Trigger dropdown allows selection of different trigger actions.
No Trigger will cause the analyzer to continue to run until the Stop
button is clicked.
Trigger Immediate will cause the analyzer to immediately start filling
the capture memory and acquisition will stop when memory is full.
Simple and Advanced Triggers will monitor all sublinks for any packet type, packet header or payload
value and trigger the analyzer to stop capturing when the trigger criteria are met.
The Trigger Position is used to set how much
acquisition memory is reserved to save trace
data prior to the trigger event vs. after the
trigger event. If a 20% trigger position is set the
analyzer will reserve 80% of the memory for
post-trigger fill. This means that if the trigger
occurs deep in the trace then 100% of the
buffer will fill, 20% before and 80% after. But if
the trigger event occurs very early in the trace,
say after only filling 5% of the total memory,
the capture will total less than 100% because
5% will be before the trigger and 80% after the
trigger for 85% total.
Simple Trigger
To set a Simple Trigger select Use Simple
Trigger from the Choose Trigger dropdown.
Double click on the packet of interest from the
left-side packet list and it will appear in the
right-side “Trigger on any of these Events”
area. Alternatively, the packets can be
dragged/dropped. If multiple packets are
chosen, the trigger machine will use OR logic.
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Double-clicking on a packet in the “Trigger on any of these Events” area will bring up the Packet Editor
(the same used for Simple Packet Search) to edit the header or payload values to trigger on. These packet
values can be saved as Favorite Packets for later re-use with either Simple Trigger or Simple Packet Search.
Simple Triggers can also be saved as Favorite
Simple Triggers for future use.
Advanced Trigger
Advanced Triggers are created and edited
using the Test Editor, which can be accessed
from the Tools menu or by selecting Advanced
Trigger from the Choose Trigger dropdown in
the Trigger Setup window and clicking New or
Load.
Once created Advanced Triggers are
automatically added to the list of available
triggers in the left pane of the Advanced
Trigger tab. Clicking Refresh will update the list
of available Advanced Triggers.
Advanced Triggers that were saved with and
then loaded from a *.pitx trace do not include
the full *.piat Advanced Trigger information
and thus are not editable; these are listed in yellow with a ToolTip "This trigger is not editable". To modify
a non-editable Advanced Trigger the user must open the *.piat file in the \AdvancedTriggers directory.
To set an Advanced Trigger, double click or drag the trigger of interest from the left pane into “Drag
Advanced Trigger Here” in the right pane.
See the Advanced Trigger Editor User Manual for details on how to construct an advanced trigger.
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The TRG IN connector on the instrument front panel (see ANALYZER FRONT PANEL - FALCON G300B/G400B
AND RAPTOR M300/M400) can be selected as an Analyzer Resource in the Simple Trigger window or in
the Advanced Trigger Editor and can be used with other packet events. When a trigger event has occurred
a TRG OUT is always asserted to the front-panel TRG OUT connector as a 1.8V ±0.3V signal.

Filter window
The Filter window, accessed from the Tools -> Filter menu, permits the filtering of specific packet types
either before or after the trace has been stored and saved.
The pre-capture Hardware Filter can eliminate Fillers, Skips, Start of
Bursts, End of Bursts and AFC_TC0 packets. The L2 Message Payload
filter keeps the first 272 bytes of the Message (a Message is the
UniPro packet containing a UFS packet) and removes the remaining
contents of the packet.
Since these are filtered out prior to trace capture they are not stored
or saved with the pitx trace.
Packets can still be used as a trigger resource even if that packet is
filtered out with the HW filter. This is because the trigger engine is
before the filter block.
Post-Capture Software Filter will capture and store all packets, but it
will suppress the selected packet types from the UniPro List window.
The Traffic Summary window will still display all packets but highlights
and deactivates those that have been filtered.
If Traffic Overview, Simple Packet Search or Bookmark navigation is
used to go to a software filtered packet the active packet displayed
will be the packet just before the filtered packet. In TV Results the “In
Test” markers will disappear with the filtered packet and the user
won’t be able to go to those filtered packets. Simple Triggers can still
be constructed with Filter enabled; if the trigger packet is filtered out
the Trigger bookmark will mark the closest unfiltered packet prior to
the trigger event.

Settings window
The Settings window is accessed from the Settings menu or the settings icon
on the toolbar. The
Settings window has separate tabs for User Preferences, Instrument Configuration, Device Configuration,
Database Configuration, Packet Display, User Toolbar, Smart Tune Equalization and Advanced Settings.
Settings can be customized for each tab and saved and loaded from files located at C:\Users\[user
name]\Documents\Protocol Insight\Falcon\Settings. Customized User Preferences are saved to a .prf file,
Instrument Configurations are saved to a .ins file, Device Configurations are saved to a .dev file, and Packet
Display settings can be saved to a .pcl file. User Toolbar settings can be saved to a .utb file, and Smart
Tune Equalization settings can be saved to a .equ file. These files can be copied so that users can carry
their own personal configuration setting with them from PC to PC.
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Note that Instrument and Device settings are saved with the trace when File->Save
Configuration/Analyzer Capture… is used, and when a trace is opened the settings saved with the trace
will override the settings in the Settings window. This allows the user to preserve the exact settings used
when the trace was captured.
User Preferences tab
User Preferences allows the user to tailor their experience and optimize application software performance
based on their typical application and most common use models. For example, a user who is primarily
interested in using the listing window to debug UniPro may choose to set the default mode to Analyzer,
turn off automatic decode and calculation of UFS packets, and set the default Packet Listing Window and
calculation settings exclusively for UniPro.

P a g e | 40

Display Preferences
Setting the Initial Mode controls which display mode is active when the software application is launched
(see WINDOWS for more information). The Primary Protocol controls whether UFS packets are decoded
(if selected in Calculation Preferences), what the default protocol is for the device Boot/Reboot button in
the toolbar, and the selected test list under Device Control in the Configuration window. The Active Packet
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Listing Window sets the default Packet List window, for example selecting UniPro will cause the UniPro
Packet List window to be the active Packet List window upon completion of a trace capture.
Correlate Scrolling in Packet Lists locks the UniPro and UFS List windows by default when scrolling.
Number Display makes large numbers more readable if the Formatted box is checked. It adds comma
separators before the decimal place and spaces after every three digits or every four hex values. This
applies only within the GUI and does not affect exported data.
Calculation Preferences
After the instrument has captured a trace it is off-loaded to the application software and the UniPro
Packet List, Packet Decode and Data View windows are immediately populated with decoded trace data.
The UFS Packet List, Packet Decode and Data View windows are also populated with decoded UFS data if
the Decode UFS box is checked under Calculation Preferences.
Background calculations then are initiated to update the UFS Traffic Overview, Events windows and
Sample List if those boxes are checked in Calculation Preferences.
The background calculations can take time and during background calculation you cannot save the trace
file unless you cancel calculations from the toolbar. To disable automatic background calculation of some
or all of the automatic calculations deselect those under “Calculation Preferences”.
If a trace has been saved without completing some or all calculations, when the file is re-opened it will
automatically start calculating in the background if a box is checked under “Calculation Preferences”.
You can force a calculation of an uncalculated trace by selecting Calculate Options from the Results menu.
The application software will still be highly responsive while it is doing background calculation, and Packet
List, Packet Decode and Data View windows are fully functional. However, until Traffic Overview is
calculated the Simple Packet Search functionality will not be available.
Show Warning Dialog On These Events
This section can be used to change warning dialog preferences if the “Do not show this message again”
box has been checked in any warning dialog.

For example, the Save Configuration and Data warning dialog will appear anytime the following actions
are performed: opening a new trace file, exiting the application, starting the analyzer, clearing results and
data, clearing Trace Validation results, or running tests.
Temporary Directory Path
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When unloading trace data from the instrument to the application software, large files are temporarily
created that can grow to be 5-10x larger than the actual *.pitx file. This can affect the performance of the
application if the target directory is located on a drive that has slower write speeds and/or insufficient
disk space.
The path where these temporary files are stored can be changed to point to another location, typically a
faster larger drive.
Instrument Configuration tab
This tab is used to configure the Falcon or Raptor instrument. To display status information about the
analyzer and exerciser instrument and UniPro link see the INSTRUMENT STATUS WINDOW . To configure
analyzer and exerciser tests see the CONFIGURATION WINDOW .
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In the Host and Device sections the sublinks can be renamed and mapped and the channels can be
defined.
Capture Options
Capture Options are used to define where traces are stored during capture. Choosing Standard will store
the trace in instrument memory, up to the maximum amount specified in the Instrument Memory Depth
field. Once the specified amount of memory has been filled, the oldest data will be discarded, and capture
will continue with a circular buffer until the analyzer is stopped or a trigger event occurs.
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Choosing Streaming will immediately output the trace via the Thunderbolt3 interface and store the data
on the controller PC hard drive. The size of the capture can be defined. Once the Disk Buffer Limit has
been reached, the oldest data will be discarded and capture will continue with a circular buffer if Wrap
Buffer is selected, otherwise the capture will stop. Note that streaming capture requires HW filtering of
fillers, skips and UFS TC0 message payload to ensure optimum bandwidth.
With streaming capture the entire trace is stored to disk before any processing, so if there is an error
during processing the trace is still on disk and the "Save debug File" will save the whole trace. If there is
an error during capture the trace will be lost.
Streaming Performance Test evaluates the Thunderbolt3 and host PC performance for the two
fundamental functions required for streaming: interface Bandwidth from instrument to the PC and Disk
Write bandwidth. 1000MB/s is considered the minimum so any test not achieving 1000MB/s is evaluated
as failing.
See APPENDIX F: STEAMING CAPTURE for more details on how streaming capture works, or APPENDIX 2:
SYSTEM REQUIREMENTS for a description of the minimum PC requirements for streaming capture.
Initial Power Mode
The Initial Power Mode settings are used to tell the analyzer the initial power mode to assume for sync to
the link, if the analyzer is capturing a link in mid-transmission. The analyzer can capture a trace from an
existing UniPro link, but the analyzer needs to be told what power mode the UniPro link is operating at.
Once the initial power mode is configurated in the Instrument Configuration window and the analyzer
syncs to the current power mode, the analyzer will continue to track the link power mode.
Other Settings
Selecting a UFS clock with the Output Clock selection is only necessary if you are using the UFS external
reference clock signal on the front panel of the instrument.

Device Configuration tab (G350B/G450B only)
The Device Configuration tab allows configuration of specific device parameters for UniPro, UFS Device
and UFS LUN Configuration.
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To change values in the UFS LUN Configuration section,
select all LUNs to be configured by using the keyboard
Shift and Control keys while selecting the LUNs of
interest. Then enter the appropriate variables to
configure the LUNs for test execution. See APPENDIX D:
DISCOVERING UFS DEVICE CONFIGURATION VALUES for more
information on how to obtain the values necessary to
properly configure the UFS device.
Note: when a trace file is saved as a PITX file, the device
configuration information is saved with the file. After
opening a PITX file if changes are made to the device
configuration using the Device Configuration window
these changes will overwrite the settings in the trace file.

Database Configuration tab

The Database Configuration tab is used to update and
save settings to repair the SQL database. See APPENDIX A:
RESETTING YOUR SQL DATABASE thru APPENDIX C:
MANUALLY INSTALLING MICROSOFT SQL SERVER for more
information on how to configure the SQL database using
this tab.
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Packet Display tab
This tab allows the user to customize most packet colors used in the List and Event views.
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User Toolbar tab

Custom toolbars can be added to the main
application. Custom toolbars are added to
the row below the factory default toolbar,
and once created the custom toolbars can be
moved to any toolbar location by clicking and
dragging the 9-dot line in the toolbar row.
To restore the original toolbars choose
View→Restore Default Layout.

Smart Tune Equalization tab
Default ATT (Attenuation), VGA (variable-gain amplification), CTLE (continuous time linear equalization),
and DFE (decision feedback equalization) settings are loaded into instrument hardware when the
application software initially connects to the Falcon and Raptor instrument.
In some instances acquiring the signal from the DUT can be problematic when test fixture trace routing
or the cabling required to connect to the test fixture causes poor signal integrity or probing issues. To
optimize signal acquisition in the case of poor signal integrity or probing issues the Falcon and Raptor
Series offer Smart Tune™ equalization capability.
Smart Tune allows the user to choose between setting fixed equalization values manually for the frontend PHY, auto equalizing using the M-PHY4.1 ADAPT capability or running auto equalization continuously
each time a Burst is opened on the link.
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To set equalization values manually individual values
can be entered in the Sublink 0 and Sublink 1
Initial/Fixed Equalization Values section or saved
values can be loaded from a file. Since the mapping of
each of the PHY equalization settings to a physical
parameter is complex, manual entry of values should
only be done on the advice and recommendation of
Protocol Insight Support.
To run Auto Equalization using the MPHY ADAPT
sequence check the box Enable Auto Equalization using
the MPHY ADAPT sequence, then execute a Link
Startup Sequence on the DUT and run the ADAPT
sequence between the Host and Device. Return to the
Equalization tab and click “Get Results”. Verify that a
successful Smart Tune was achieved, see Verifying
Smart Tune Results section. If successful, Smart Tune
can safely be left with Enable Auto Equalization using
the MPHY ADAPT sequence checked, in this mode it will
equalize every time ADAPT is ran. Optionally, the
results can be saved and used as fixed values, see the
Saving and Applying Results section. If the Smart Tune
was unsuccessful, see Verifying Smart Tune Results
section, try repeating the entire process by running the
ADAPT sequence again. If the Smart Tune results
continue to be unsuccessful refer to the
Troubleshooting Auto Equalization using the MPHY ADAPT sequence section. Note that because ADAPT is
only supported in M-HY 4.1 for HS-G4 this capability does not support lower HS speeds.
Troubleshooting Auto Equalization using the MPHY ADAPT sequence: These troubleshooting
instructions are intended for Analyzer mode.
•

•

If the results show Abort > 0 and Done == 0: This indicates that PHY is not seeing enough symbols
to complete a Smart Tune. Verify that the Host and Device ADAPT sequence length is long
enough, Falcon/Raptor has a RX_HS_ADAPT_LENGTH_COARSE_Capability value of 0x91
(course,17), thus the Host and Device must both use an ADAPT_length of 0x91. If either Host or
Device is does not use an ADAPT_length of 0x91 you can change the value after Link Startup but
before the power mode change. Set the attribute PA_PeerRxHsAdaptInitial (0x15D3) to 0x91 in
both the local and peer DME’s.
If the host and device ADAPT sequences length is long enough but still Abort > 0, it could be
caused but the PHY falsely detecting a Tail of Burst to soon. Select the Enable TOB Filter, start
with the default value of 0x100000 for symbols to ignore. You can increase or decrease the
symbols to ignore based on the ADAPT length. If you continue to have issues you can try Auto
Equalization continuously or contact Protocol Insight Support with traces that show link startup,
power mode change and the ADAPT sequence. Also take screen captures of the Equalization
Results after each attempt.
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To run Auto equalization continuously select Enable Auto Equalization continuously. Then execute a Link
Startup Sequence on the DUT and change power mode to the fastest mode supported and begin sending
a good equalization data pattern. To achieve the best results Smart Tune typically requires ~10MB of
random data to be sent in a single burst. The recommended way to send random data for Smart Tune is
in fast mode with scrambling enabled, because scrambled fillers are a pseudorandom data pattern. Verify
that the analyzer is seeing data by observing the Hardware Counters increasing in the Instrument Status
window. Return to the Equalization tab and click “Get Best EQ Values”. This will determine the maximum
FOM value by observing equalization results for 5 seconds, then it will save the equalization values with
the best FOM Quality. Once completed you should observe successful results, see Verifying Smart Tune
Results section. If successful, the results should be saved and used as fixed values, see the Saving and
Applying Results section. Auto Equalization continuously mode should only be used to get equalization
results and it is not recommended to leave Smart Tune in the Auto Equalization continuously mode. This
capability supports all HS speeds, including HS-G1 to HS-G4B.
The Equalization Results section shows the value of the equalization settings that are currently being
applied in the PHY. When running Smart Tune equalization, the PHY will try to find the ideal equalization
values (ATT, VGA, CTLE, DFE). The status information (FOM (Figure of Merit), Abort, Done) will indicate
the quality of the Smart Tune equalization. The Done counter indicates how many times equalization
tuning successfully completes. When running Smart Tune this counter should increment every time a new
Smart Tune is ran. The Abort counter indicates how many times equalization tuning fails, failures typically
occur because the PHY did not see enough bytes of data in a single burst, typically ~10MB are required to
be sent in 1 burst for the PHY to correctly equalize. The FOM value indicates how good the equalization
values are. The larger FOM value the better the equalization is, see Table 1 below for FOM Value to FOM
Quality mapping. Poor FOM Quality typically indicates poor signal integrity which results in errors being
captured. The FOM value is the perceived quality of the equalization, the only definitive test is if the RX
can capture error free. There are instances where the FOM is a false large value, meaning the FOM Quality
is a Good value but errors are still captured. This typically happens when the data pattern that was used
for tuning is not random data, FILLERS that are NOT scrambled is the worst data for Smart Tuning.
Verifying Smart Tune Results: A successfully Smart Tune is indicated by the Done counter value >= 1,
values for all the PHY values should have changed from the previous value and the Figure of Merit value
(FOM) should be Good quality, see Error! Reference source not found..
•
•
•
•

Successful Smart Tune is indicated by (Done >= 1 and FOM Quality = Good)
Failed Smart Tune is indicated by (Done == 0 and Abort >= 1).
Poor quality Smart Tune is indicated by (Done >= 1 and FOM Quality = Poor).
Smart Tune did not run if Done == 0 and Abort == 0.

FOM Quality
Good
Poor
Bad

FOM Value
>=0x60
<0x60 & >= 0x50
<0x50

Table 1 FOM Value to FOM Quality Mapping
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Saving and Applying Results: To save the values select “Copy Results to Fixed Equalization Values” to load
the values into the PHY and switch to Fixed Equalization mode by unchecking the Enable Auto Equalization
using the MPHY ADAPT sequence and Enable Auto Equalization continuously.

Advanced Settings tab
CAUTION: the Advanced Settings tab requires expert knowledge of the instrument and the Device Under
Test and test fixture configurations. The Advanced Settings tab should only be used on the advice and
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recommendation of Protocol Insight Support. Before beginning the user must acknowledge this by
checking the box that “I understand how to use Advanced Settings”.

For information on how to use the Advanced Settings tab contact your local Protocol Insight
representative or support@protocolinsight.com.
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Instrument Status window
This window is used to display status information about the
analyzer and exerciser instrument and UniPro link operation.
To configure the instrument see the INSTRUMENT
CONFIGURATION TAB under Setting on the menu. To configure
analyzer and exerciser tests see the CONFIGURATION WINDOW .
The Analyzer section of Instrument Status is used to display
analyzer and trigger status, and the analyzer memory Capture
Options configured.
Analyzer Memory is displayed if Standard is selected as the
Capture Type in Capture Options in the Instrument
Configuration tab of the Settings window. The amount of
embedded Instrument Memory Depth selected is displayed
along with a percentage representing the amount of memory
filled relative to the amount of memory allocated.
The analyzer always reserves the amount of memory after the
trigger that is set with the Trigger Position; if a 20% trigger
position is set the analyzer will reserve 80% of the memory for
post-trigger fill. What this means is that if the trigger occurs
deep in the trace then 100% of the memory buffer will fill, 20%
before and 80% after. But if the trigger event occurs very early
in the trace, say after only filling 5% of the total memory, the
capture will total less than 100% because 5% will be before the
trigger and 80% after the trigger for 85% total. See TRIGGER
SETUP WINDOW for more information.
Streaming File Usage is displayed if Streaming is selected as the
Capture Type in Capture Options in the Instrument
Configuration tab. Streaming File Usage shows the amount of
Disk Buffer Limit allocated and the percentage of that buffer
that has been filled by the capture. Streaming Buffer Usage
displays a graphical representation of the amount of the
instrument’s embedded memory and the controller PC’s RAM
that is being used as a buffer as the trace is being written to the
Streaming File on disk. See APPENDIX F: STEAMING CAPTURE for
more information.
The Link Power Mode section provides real-time link status and
power mode information.
The Hardware Counters section provides insight into the realtime traffic on the link by counting the number of M-PHY symbols
and symbol errors observed on each sublink/lane. Symbol errors
in the Instrument Status window are KCode raw bit capture
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errors, typically caused by signal integrity problems, probing issues or M-PHY issues. The Hardware
Counters will increment independently of if the analyzer Run button is selected.

Application Status
The Application Status window can be accessed from the
toolbar by clicking on the blue info icon to the right of the
application status bar in the Tool Bar.
The Application Status window will display progress on any
computationally intensive functions being performed by the
application, such as file opens, Traffic Overview and Events
indexing, zooms, searches, and Trace Validation runs.
If the Application Status window is opened before a
Configuration/Analyzer Capture file is opened the status
window will display all computations while the trace file is
being opened.
Application Status messages will be automatically cleared
when a new trace is captured or loaded from a file.

Eye Monitor
The Eye Monitor window, accessed from Menu→Tools→Eye Monitor, constructs an eye diagram of the
link to determine the link quality.
To develop useful eye diagram measurements Eye Monitor must be run against high speed traffic with
lots of transitions, preferably HS-G4B in NonAuto mode with Scrambling enabled.
To perform an eye diagram measurement:
1. Click Connect on the toolbar. The application will connect to the instrument hardware and begin
tracking symbols on the link.
2. Initiate suitable traffic across the link and verify that the analyzer is seeing that traffic by observing
the counters increasing under Hardware Counters in the Instrument Status window.
3. Open the Eye Monitor tool and choose which Lanes to measure, choose what Eye Diagram
Resolution to run the measurement at, and which Sample Points to measure the eye at.
4. Click Start Eye Measurement.
After the measurement is complete the results can be saved and shared by clicking the Save… button.
Qualitative measurements can be done for jitter, noise, and eye opening by dragging the X and Y cursors
in each eye measurement panel, delta values will be displayed in the cursor tooltip.
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Menu Functions
Many menu functions are duplicated on the easy to access TOOL BAR. This section provides additional
detail for the more complex functions.

File Menu
All trace data, including trace indexing for Traffic Overview and Events window, Trace Validation results,
and any settings from the Configuration windows are saved in a file with file extension of .pitx (Protocol
Insight Test).
→Open Configuration…
This function is used to open a previously saved *.pitx file to restore the Configuration Window and all
instrument and device configuration settings.
File→Open Configuration/Analyzer Capture…
This function is used to open a previously saved *.pitx file including the instrument and device
configuration, the trace capture, trace indexing for Traffic Overview and Events views, and Trace
Validation results.
File→Open Recent Configuration/Analyzer Capture…
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This function is used to open recently used traces and/or configuration files.
File→Save Configuration…
This function is used to save the instrument and device configuration. The file extension of .pitx is used
for these files.
File→Save Configuration/Analyzer Capture…
This function is used to save instrument and device configuration plus the trace capture, trace indexing
for Traffic Overview, Trace Validation results and Events view indexing. The file extension of .pitx is used
for these files.
File→Refresh Advanced Trigger Tests
Updates the list of advanced triggers in the Advanced Trigger window with the advanced triggers in
<User>\Documents\Protocol Insight\Falcon\ AdvancedTrigger.
File→Refresh Trace Validation Test List
Updates the list of Trace Validator test categories and custom Trace Validator test cases in the
Configuration windows from the categories and test cases in <User>\Documents\Protocol
Insight\Falcon\CustomTests.
Directories in <User>\Documents\Protocol Insight\Falcon\CustomTests are displayed in italics as
categories in the Configuration window test lists, appended to the bottom. For example, the directory
<User>\Documents\Protocol Insight\Falcon\CustomTests\ProjectX would appear in the test lists as the
category ProjectX. Custom tests must be saved in categories (sub-directories). New categories can be
created by adding new sub-directories in <User>\Documents\Protocol Insight\Falcon\CustomTests with
File Explorer.
File→Refresh Stimulus Test List
Updates the list of custom stimulus test categories and custom stimulus test cases in the Configuration
windows from the categories and test cases in <User>\Documents\Protocol Insight\Falcon\CustomTests.
Directories in <User>\Documents\Protocol Insight\Falcon\CustomTests are displayed in italics as
categories in the Configuration window test lists, appended to the bottom. For example, the directory
<User>\Documents\Protocol Insight\Falcon\CustomTests\ProjectX would appear in the test lists as the
category ProjectX. Custom tests must be saved in categories (sub-directories). New categories can be
created by adding new sub-directories in <User>\Documents\Protocol Insight\Falcon\CustomTests with
File Explorer.
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File→Export Decoded Packets as CSV
CSV export can be performed for a defined section of a trace or the entire trace:

The data columns exported to .csv are same as the columns that are defined in UniPro/UFS Packet List
window. Enabling the Packet Data: Append to Each Raw can export all raw data to .csv with the columns
selected. The export .csv data will separate by commas.
File→Export Analyzer Capture Range
A pitx file can be saved that only includes trace data between two selected bookmarks. Any existing
bookmarks in the file can be used for to define export boundaries:

This export file will also include the configuration settings.
File extensions:
Some file extensions have changed with v1.8.0. Legacy file extensions are still supported for backward
compatibility. Here is a complete list of all file extensions:
Traces (including the configuration & analyzer captures) *.pitx
Settings
User Preferences *.prf
Instrument Configuration *.ins
Device Configuration *.dev
Database Configuration *.dbc
Packet Display *.pcl
User Toolbar *.utb
Smart Tune Equalization *.equ
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Advanced Settings *.ads
Triggers
Advanced Trigger File *.piat
Simple Trigger File *.smp
Packet File *.pkt
Simple Search
Packet File *.pkt
Trace Validation
Validation, state machine and diagram files *.pitv (v1.8.0 and later)
Validation files *.piv (legacy files prior to v1.8.0)
State machine files *.sm (legacy files prior to v1.8.0)
Diagram files *.sm.diagram (legacy files prior to v1.8.0)
Stimulus Editor/Builder files
Stimulus Editor Files *.pie (Stimulus files for v1.8.0 and later)
Stimulus Builder Files *.pis (legacy Stimulus files prior to v1.8.0, deprecated)

Test Menu
Test→Run
Starts the Stim and Trace Validation tests selected and configured in the Configuration windows.
Test→Stop
Stops the tests that are currently running.

Results Menu
Results→Clear Stimulus Results
Results→Clear Trace Validation Results
Results→Clear All Results and Data
Selecting these menu options will clear the respective Results window or windows of all test results.
Results→Calculate Options
This forces a calculation of any uncalculated trace data. Only valid options that have not been calculated
will be active.

Reports Menu
Reports→Trace Validation Results
Reports→Stimulus Results
Summary reports can be created by configuring the TV Results and Stimulus Results windows
(grouping, summarizing, sorting, filtering and expanding levels) and then printing them from this
menu. This menu will reproduce exactly what is reflected in the Results window to a PDF file.
Stimulus Results can also be exported to a CSV or XML file.
Reports→UniPro Packet List
Reports→UFS Packet List
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A Packet List report can be generated from a Packet List window.
This menu will reproduce exactly what is reflected in the Packet List window to a PDF file.

View Menu
Any windows that have been closed will be opened by selecting these options. Restore Default Layout will
restore the default window and toolbar layout.

Analyzer Control Menu
Analyzer Control→Connect
Analyzer Control→Start
Analyzer Control→Stop
These menu items provide the same functionality as the Analyzer status/control tool bar. Clicking Connect
will establish a connection between the analyzer application and the instrument hardware if it is available.
Clicking Start or Stop will begin or end a trace capture.

Tools Menu
Tools→ Trigger
The Trigger dialog is used to create, modify and set triggers.
Tools→ Filter
Selecting this menu option will open the Filter window. See FILTER WINDOW for more information.
Tools→ Eye Monitor
Selecting this menu option will open the Eye Monitor dialog to perform eye measurements on the link.
See EYE MONITOR for more information.
Tools→ Editor
Editor→ Open Editor
This launches Protocol Insight’s Visual Studio Editor tool as a separate application for editing
existing or creating new Advanced Triggers, Trace Validation or Stimulus tests.
Editor→New Advanced Trigger
This launches Protocol Insight’s Visual Studio Editor tool as a separate application and opens a
new Advanced Trigger file.
Editor→New Trace Validator
This launches Protocol Insight’s Visual Studio Editor tool as a separate application and opens a
new Trace Validator project.
Editor→New UniPro Stimulus
This launches Protocol Insight’s Visual Studio Editor tool as a separate application and opens a
new UniPro Stimulus test project.
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Editor→New UFS Stimulus
This launches Protocol Insight’s Visual Studio Editor tool as a separate application and opens a
new UFS Stimulus test project.
Tools→ Streaming Statistics
The Streaming Statistics dialog displays information on the
streaming performance (bandwidth and bottlenecks) of the
Thunderbolt3 connection between the instrument and the
controller PC. This streaming data is collected continuously any
time Streaming Capture is used.
Tools→ Save Debug File

Settings Menu
Settings → User Preferences
See USER PREFERENCES for more information.
Settings → Instrument Configuration
See INSTRUMENT CONFIGURATION TAB for more information.
Settings → Device Configuration
See DEVICE CONFIGURATION TAB (G350B/G450B ONLY) for more information. This will be greyed out and
inactive if Analyzer mode is selected.
Settings → Database Configuration
See DATABASE CONFIGURATION TAB for more information.
The Microsoft SQL Server and instrument-specific database settings are
configured automatically with the initial software installation. However, in
some instances it may be necessary to reset your database settings,
reconfigure your database or re-install it manually from scratch. The
Database Configuration dialog is used to update and save settings to repair
the database. See APPENDIX A: RESETTING YOUR SQL DATABASE thru
APPENDIX C: MANUALLY INSTALLING MICROSOFT SQL SERVER for more
information.
Settings → Packet Display
See PACKET DISPLAY TAB for more information.
Settings → User Toolbar
See USER TOOLBAR TAB for more information.
Settings → Smart Tune Equalization
See SMART TUNE EQUALIZATION TAB for more information.
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Settings → Advanced Settings
See ADVANCED SETTINGS TAB for more information.

Help Menu
Help → User Manuals
User Manuals are provided for the instrument, Advanced Trigger, Trace Validation Editor, and Stimulus
Editor.
Help → Compatibility-> Test Case Revisions and Interpretations…
Selecting Test Case Revisions and Interpretations… will launch a web browser and navigate to a web page
which provides regularly updated information on test cases that have been revised or required
interpretation to develop.
Protocol Insight may revise certain test cases from the strict interpretation of the UniPro or UFS CTS to
facilitate effective and accurate test execution. Any revisions are described here.
Interpretation of some test cases may have been required to account for ambiguities in the UFS spec, the
UniPro spec, and/or the CTS specs. To complete the development of the CTS tests Protocol Insight may
have made certain interpretations which could alter the results of the test cases; those interpretations
are described here.
Help → Compatibility->Known Issues…
Selecting Known Issues… will launch a web browser and navigate to a web page which provides regularly
updated information on any known issues with the application software or firmware.

Post-Capture Analysis
Trace Validation
Trace Validation (TV) is a state machine analysis tool that analyzes captured traces using specific and|or
logic and states to find problems and events. TV tests can be run against any captured trace as a complete
post-capture analysis tool for search, pass/fail testing, stress test analysis or for general debug.
There are generally four types of TV tests that can be run: pre-defined CTS tests, debug tests, SearchTVs
and custom tests. The application software library includes hundreds of pre-defined CTS, debug and
search TVs that can be used as-is or modified and saved as their own unique analysis test cases. And the
user can use Trace Validation Editor to create their own custom TV tests.
Pre-defined CTS tests are supplied with the application software library for most UniPro and UFS CTS tests
defined by the respective standards organizations.
When these CTS tests are executed the Exerciser inserts a specific Protocol Insight marker packet into the
trace to indicate the beginning of each CTS test in the trace (see TEST EXECUTION AND TRACE VALIDATION
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for more information). If TV does not find the marker packet TV will not
complete and will instead generate the message “State machine did not run”.
For this reason, the TV CTS tests supplied with the application software library should only be used to
analyze traces generated with the Exerciser with the matching CTS Stim test case containing a marker
packet.
The pre-defined CTS tests are designed to follow the exact packet sequence defined in each CTS. For
example, in JESD224A, the CTS test 8.1.3 “UFS_ContextManagement_03” requires the following specific
packet sequence:
1.
2.
3.
4.

Issue Query Request Write Attribute command to set wContextConf for read and write operation
Issue READ (10) command
Issue WRITE (10) command
Issue Query Request Write Attribute command to clear wContextConf (INDEX = N).

Therefore, the TV test for UFS CTS 8.1.3 specifically requires a Query Request Write Attribute command
followed by a Read (10) followed by a Write (10) followed by another Query Request Write Attribute
command. If these packets are not found in this sequence the test will fail.
Debug tests are designed to analyze any trace, not just ones generated by the Exerciser for CTS, to find
issues that are commonly associated with UniPro or UFS turn-on problems. Examples include Link Startup
problems and Powermode Change failures. Debug tests are intended to be used with traces captured in
either exerciser or analyzer mode. If no states in the captured trace match the criteria of the debug TV,
the message “State machine did not run” will be generated. See APPENDIX E: DEBUG TEST DESCRIPTIONS for
a list and explanation of these tests.
SearchTVs are tests created by Protocol Insight to search a trace for specific conditions. The application
software library includes three search TVs, “Find UniPro Error Packets“, “Find UFS Error Packets” and “Find
Protocol Insight CTS Markers”.
Custom TV tests can be created by the user, either from scratch or from a pre-defined test in the
application software library. See the separate Trace Validation Editor User Manual for more information.

Trace Validation Results - Group and Summarize
Analysis of results in the TV Results window can be done with grouping. To group click on any column
header and drag into the Test Results field. This will summarize the results with an item count of
occurrences. Multiple column headers can be dragged into the Test Results field (1) to create tiered
groupings for analysis:

P a g e | 62

Figure 2: Grouping and Summarizing

The item count represents the number of items in the grouping below, so in this example (2) “Test Name:
UniPro: Power Mode Change” counted 4 items, representing 4 different test results. This item count
summing function can be manipulated with a high degree of flexibility by reordering the groupings to
count different items in addition to tests, such as number of Failures (Status) or Rules.
Summary Status flag: for any grouping of results the summary status flag represents the worst-case result
of the grouping (3). In this example, 4 results were determined for “Test Name: UniPro: Power Mode
Change”, and the worst result was a Failure so “Test Name: UniPro: Power Mode Change” is marked as
Failure.

Trace Validation Results - Sort and Filter
In the TV Results window any column header can be clicked to filter out results or to sort results by that
column:
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Figure 3: Sorting and Filtering

UniPro and UFS Packet List windows
The Packet List windows display all packets. See UNIPRO AND UFS PACKET LIST WINDOW for more details.

UniPro and UFS Events windows
The Events windows display all events in a trace, with separate rows for significant events such as speed
changes, UniPro packets and UFS READs and WRITEs. Zooming is can be accomplished by dragging a zoom
box in the Events window, and the controls on the left side of the Events window can undo zoom or
otherwise control display zooming. See UNIPRO EVENTS WINDOW for more details.

Packet Decode and Data View windows
To display the protocol decode of a packet of interest in the Packet Decode window click on the packet in
the TV Results window or in the appropriate Packet List window. Hovering over a bit in the Packet Decode
window displays additional decode information Selecting 8, 16, or 32 defines the bit width of the display.
Full payload is displayed in the Data View window. See PACKET DECODE WINDOW and DATA VIEW WINDOW
for more details.

Analysis Reports
TV Results and Packet List reports can be created by configuring the appropriate window and then printing
it. See REPORTS MENU for more information.
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Operational Overview and Theory of Operation
Trace Validation is the analysis engine for compliance/conformance testing (CTS), corner case, margin and
automated stress testing, and sniffer-style trace capture, analysis and debug.
Trace Validation is a complex state machine system that processes analyzer traces algorithmically and
applies state machine logic to packet sequences to verify conformance or compliance to the specifications.

Figure 4: Example UniPro Power Mode Change Trace Validation State Machine

Interpreting Trace Validation Results
The Trace Validation engine performs protocol sequence and packet inspection with five possible status
results for each rule check displayed in the Trace Validation Results window:
Failure
Any protocol sequence or packet that does not meet a rule specified in MIPI UniPro v1.1 CTS, the
JEDEC JESD224 or JESD224A CTS, or as defined in a custom test case
Warning
Any protocol sequence or packet that does not conform to
a “shall” specified in MIPI UniPro v1.61 spec, JEDEC
JESD220x spec, or as defined in a custom test case
Pass
Any protocol sequence or packet that conforms to the
UniPro spec and CTS and JEDEC spec and CTS.
Info
Info messages communicate the progress during the test
or information about the packets, and are typically
followed by a status result such as Pass or Failure. See
example to the right, where there are several Info
messages followed by a Success message and Pass status.
Debug

(TV mode only)
Provides information on state machine execution of an inspection rule in Trace Validation if debug
hooks were placed in the TV test case:
Indicates an Action was executed. This could be a Log Message Action, Counter Action, or
a Set or Modify Variable Action run by either a State or an Event.
Indicates that an Event fired and triggered a transition to a new State. Events fire when
all their Validators are true.
Indicates that the Trace Validation engine transitioned into a new State.
Indicates that a Validator was tested and the result was true.
Indicates that a Validator was tested and the result was false.
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The results can be grouped, summed, sorted and filtered by various test parameters or packet
characteristics. See TRACE VALIDATION RESULTS - GROUP AND SUMMARIZE and TRACE VALIDATION RESULTS SORT AND FILTER for more information.

Test execution and Trace Validation analysis for Falcon exerciser
To execute compliance/conformance testing (CTS), corner case, margin and automated stress testing in
“CTS and Exerciser + Analyzer” mode the test cases are initiated by the exerciser and the Trace Validation
engine is used to verify the results. Trace Validation examines the trace to verify that the protocol
sequences and packets conform to the UniPro or UFS CTS, specifications or custom tests. This flowchart
shows the operation:

Figure 5: Test executive exerciser operation

For UniPro CTS testing, to locate the beginning of each test case in the trace a PACP_SET_req marker
packet is inserted followed by the packet(s) necessary to commence the test. The marker packet contains
a value that uniquely identifies the test case:
•

The PACP_SET_req MIBattribute value identifies the author of the test case. The predefined
ranges are listed below.
•
•
•

•

0xFFFF – Test case authored by Protocol Insight
0xFF00-0xFFFE – This range reserved
0xF000-0xFEFF – Range available range for customer defined test cases.

The MIBvalue identifies the specific test being executed:
•

Domain (8 bits) – Used to define a category of test case for the given owner. Existing Protocol
Insight domains are:
• 01 - CTS specific test cases
• 02 - Power mode tests
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•

Case ID (24 bits) – Identifies a specific test case within a given domain. Protocol Insight test
cases follow a major, minor, revision style using 8 bits for each.

For example, the CTS test case 1.1.4 Invalid Configuration Request written by Protocol Insight
would have a complete ID of 0x01010104.
For UFS CTS testing, to locate the beginning of each test case in the trace a NOP OUT packet is inserted
with the follow reserved bits set:
•

Reserved Bytes 12 & 13 – Place the Protocol Insight Flag - 0xFFFF
•
•
•

•

0xFFFF – Test case authored by Protocol Insight
0xFF00-0xFFFE – This range reserved
0xF000-0xFEFF – Range available range for customer defined test cases.

Reserved Bytes 14 – 17 –The four parts of the test case ID
•

Domain (8 bits) – Used to define a category of test case for the given owner. Existing Protocol
Insight domains are:
▪ 01 - CTS specific test cases
▪ 02 - Power mode tests

•

Case ID (24 bits) – Identifies a specific test case within a given domain. Protocol Insight test
cases follow a major, minor, revision style using 8 bits for each.

Test execution and Trace Validation analysis for analyzer
This flow charts shows the operation of the test executive for “sniffer” style Trace Validation analysis:

Figure 6: Trace Validation operation
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Warranty
For Product(s):
Protocol Insight warrants that this product will be free from defects in materials and workmanship for a
period of one (1) year from the date of shipment. If any such product proves defective during this warranty
period, Protocol Insight, at its option, either will repair the defective product without charge for parts and
labor, or will provide a replacement in exchange for the defective product. Parts, modules and replacement
products used by Protocol Insight for warranty work may be new or reconditioned to like new performance.
All replaced parts, modules and products become the property of Protocol Insight.
In order to obtain service under this warranty, Customer must notify Protocol Insight of the defect before
the expiration of the warranty period and make suitable arrangements for the performance of service.
Customer shall be responsible for packaging and shipping the defective product to the location designated
by Protocol Insight, with shipping charges prepaid. Customer shall be responsible for paying all shipping
charges, duties, taxes, and any other charges for products returned to any locations.
This warranty shall not apply to any defect, failure or damage caused by improper use or improper or
inadequate maintenance and care. THIS WARRANTY SHALL NOT APPLY TO ANY DAMAGE TO
INSTRUMENT FRONT-PANEL CONNECTORS. Protocol Insight shall not be obligated to furnish
service under this warranty a) to repair damage resulting from attempts by personnel other than Protocol
Insight representatives to install, repair or service the product; b) to repair damage resulting from improper
use or connection to incompatible equipment; c) to repair any damage or malfunction caused by the use of
non-Protocol Insight supplies; or d) to service a product that has been modified or integrated with other
products when the effect of such modification or integration increases the time or difficulty of servicing the
product.
THIS WARRANTY IS GIVEN BY PROTOCOL INSIGHT WITH RESPECT TO THE PRODUCT IN
LIEU OF ANY OTHER WARRANTIES, EXPRESS OR IMPLIED. PROTOCOL INSIGHT AND ITS
VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR
A PARTICULAR PURPOSE. PROTOCOL INSIGHT' RESPONSIBILITY TO REPAIR OR REPLACE
DEFECTIVE PRODUCTS IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE
CUSTOMER FOR BREACH OF THIS WARRANTY. PROTOCOL INSIGHT AND ITS VENDORS
WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES IRRESPECTIVE OF WHETHER PROTOCOL INSIGHT OR THE VENDOR HAS
ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.
For Software and Documentation:
Protocol Insight warrants that (a) the physical medium on which this Software or Documentation is
distributed is free from defects in materials and workmanship under normal use; (b) the Software will
perform substantially according to the relevant Documentation when used as instructed in the
Documentation; and (c) Protocol Insight has the right and authority to grant the License and to perform
its other obligations under this Agreement. This limited warranty shall expire 30 days after delivery of the
Software to Licensee. To the fullest extent permitted by law, THE ABOVE-STATED LIMITED WARRANTY IS
THE ONLY WARRANTY MADE BY PROTOCOL INSIGHT OR ITS LICENSORS AND REPLACES ALL OTHER
WARRANTIES, EXPRESS OR IMPLIED, AND PROTOCOL INSIGHT DISCLAIMS AND LICENSEE WAIVES ALL
OTHER REPRESENTATIONS, WARRANTIES, OR CONDITIONS, INCLUDING WITHOUT LIMITATION, THE
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IMPLIED WARRANTIES OF TITLE, MERCHANTABILITY, NONINFRINGEMENT, AND OF FITNESS FOR A
PARTICULAR PURPOSE.
Notwithstanding the foregoing, PROTOCOL INSIGHT AND ITS PROTOCOL INSIGHTS ARE NOT LIABLE TO
LICENSEE FOR ANY DAMAGES, INCLUDING, WITHOUT LIMITATION, DIRECT, COMPENSATORY, SPECIAL,
INCIDENTAL, EXEMPLARY, PUNITIVE, OR CONSEQUENTIAL DAMAGES, CONNECTED WITH OR RESULTING
FROM THIS AGREEMENT OR LICENSEE'S USE OF THE LICENSED PRODUCTS, REGARDLESS OF ANY
KNOWLEDGE OF OR NOTIFICATION TO PROTOCOL INSIGHT OF THE LIKELIHOOD OF SUCH DAMAGES
OCCURRING. In any event, Protocol Insight’s total aggregate liability for all damages, losses, claims,
liabilities, expenses and costs arising from or related to the products under any and all theories of liability
shall be the amount paid by Licensee to Protocol Insight for the product in question.
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Appendix A: Resetting Your SQL Database
Follow these steps to reset your SQL database:
1. Launch Protocol Insight application software
2. Select Settings → Database Settings
3. Enter the following
a. Server Name: "localhost\ProtocolInsight"
b. Database Name: "ProtocolInsight"
c. Authentication Type: "Windows Authentication"
4. Click Repair Database.

5. Click Yes on the warning message box
6. You should get a dialog box saying "Database was restored successfully"
7. You can now use the software normally
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Appendix B: Reconfiguring your SQL Database
Follow these steps to reconfigure your SQL database:
1. Launch Protocol Insight application software
2. Select Settings → Database Settings
3. Enter the following
Server name: Enter the SQL Server instance to connect to. By
default this should be localhost\Protocolinsight.
Database Name: The name of the database on the server. By
default this is Protocolinsight.
Authentication Type: Two authentication modes are available when connecting to an instance of
the Database Engine:
Windows Authentication - Microsoft Windows Authentication mode allows a user to connect
through a Windows user account.
SQL Server Authentication - When a user connects with a specified login name and password
from a non-trusted connection, SQL Server performs the authentication itself by checking to
see if a SQL Server login account has been set up and if the specified password matches the
one previously recorded. If the Authentication Type selected is SQL Server Authentication:
User Name: The SQL Server login id to connect to SQL Server should be “sa” if you are
using the Default Password (see below).
Password: The Password to connect to SQL Server with.
Use Default Password: This will override the password with the default password for the
sa account. User Name must be “sa” and the SQL Server install must be the default from
installing the software.
When you have entered all the data, click Test Connection to make sure the server, database, and
security are valid.
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Appendix C: Manually Installing Microsoft SQL Server
Follow these steps to manually install and configure your SQL database:
NOTE: If you are manually installing during setup, start with Step 3.
1. Obtain the SQL Server 2017 Express edition installation media from Microsoft
a. https://www.microsoft.com/en-us/download/details.aspx?id=55994
b. Click Download
2. Run SQLServer2017-SSEI-Expr.exe from your download location.
3. On the "Select an installation type" screen, choose Custom

4. Select a download media location and Click Install
At this point the installation files will be downloaded from Microsoft. Once complete, the
installation should start.
5. SQL Server Installation Center - Click Installation on the list of options in the left pane
6. Click " New SQL Server stand-alone installation or add features to an existing installation"
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7.
8.
9.
10.

Install Rules – Verify that you don't have any required updates and click Next
Installation Type – Choose Perform a new installation of SQL Server 2017 and click Next
License Terms – Check I accept the license terms and click Next
Features Selection – Click the Unselect All button and then choose only the "Database Engine
Services" feature. Click Next (You can optionally change the installation drive if you need to
install to a drive other than C:\)

11. Instance Configuration – Choose Named Instance and Enter "ProtocolInsight" as the instance
name. The Instance ID should automatically update to "PROTOCOLINSIGHT". Click Next.
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12. Server Configuration – Leave the default options, click Next.
13. Database Engine Configuration – Click the Add Current User button if the current windows user
is not listed in the Specify SQL Server administrators box. Click Next.
14. Wait for the installation to complete and click Finish.
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Appendix D: Discovering UFS Device Configuration Values
Select LUN 0, Boot LUN, UFS Device LUN, Report LUNs, and NONE LUN and then run the following tests to
obtain the necessary device information to configurate the Device:
•

•

•

•

•

•
•
•

Device Configuration: “Device Descriptor Values”
o All values for this can be found by looking at the response of test case 8.4.1
ReadDescriptor_01
Device Configuration: “Geometry Descriptor Values”
o All values for this can be found by looking at the response of test case 8.4.9
ReadDescriptor_09
UFS LUN Configuration: “Read-Write recovery mode page”
o These values are vendor specific, default to unselected. The standard does not define
which Read-Write Error Recovery mode page fields are changeable.
UFS LUN Configuration:
o Some values for this can be found by looking at the response of test case 8.4.3
ReadDescriptor_03
o Select all configured LUNs in the Configuration window
▪ Set the correct values for the following:
▪ bProvisioning set to 0x2 or 0x3
▪ MaxContextID=0 can be found from wContextCapabilities, bits [3:0] is
MaxContextID
Run test case 7.7.2 ReadCapacity_10. In the LUN Configuration pane set the MAX addressable
LBA from the RETURNED LOGICAL BLOCK ADDRESS response field in the READ CAPACITY 10
response packet. Also set the qLogicalBlockCount and bLogicalBlockSize.
Min Page code should be fine at 0x02 (Vendor Specific)
IMMD (Vendor Specific)
“Mode Page PS Values” and “Mode Saveable”
o All values for this can be found by looking at the response of test cases 7.3.2
ModeSense_02, 7.3.6 ModeSense_06 and 7.3.10 ModeSense_10.
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Appendix E: Debug Test Descriptions
UFS Debug Tests
UFS Stimulus
The following stimulus tests perform as the test name implies. For example, the “Read BusyRTC Flag”
reads the BusyRTC flag.
Read BackgroundOpsEn Flag
Read BusyRTC Flag
Read Configuration Descriptor

Read bBootLunEn Attribute
Read bConfigDescrLock Attribute
Read bCurrentPowerMode Attribute

Read Device Descriptor
Read Device Health Descriptor

Read bDeviceCaseRoughTemperature Attribute
Read bDeviceFFUStatus Attribute

Read Device Init Flag
Read DeviceLifeSpanModeEn Flag
Read Geometry Descriptor
Read Interconnect Descriptor
Read Manufacturer Name String Descriptor
Read OEM ID String Descriptor
Read PermanentWPEn Flag
Read PermanentlyDisableFwUpdate Flag
Read PhyResourceRemoval Flag
Read Power Parameters Descriptor
Read PowerOnWPEn Flag
Read Product Name String Descriptor

Read bDeviceTooHighTempBoundary Attribute
Read bDeviceTooLowTempBoundary Attribute
Read bMaxDataInSize Attribute
Read bMaxDataOutSize Attribute
Read bOutOfOrderDataEn Attribute
Read bPSAState Attribute
Read bPurgeStatus Attribute
Read bRefClkFreq Attribute
Read bRefClkGatingWaitTime Attribute
Read bRefreshFreq Attribute
Read bRefreshMethod Attribute
Read bRefreshUnit Attribute

Read Product Rev Level String Descriptor
Read PurgeEnable Flag

Read dDynCapNeeded Attribute
Read dPSADataSize Attribute

Read RPMB Unit Descriptor
Read RefreshEnable Flag
Read Serial Number String Descriptor

Read dSecondsPassed Attribute
Read wContextConf Attribute
Read wExceptionEventControl Attribute

Read Unit Descriptor
Read bActiveICCLevel Attribute

Read wExceptionEventStatus Attribute

Read bBackgroundOpStatus Attribute

UFS Trace Validation
Command Response
This test checks that every Command sent by the tester receives a Response from the DUT.
Latency
This Trace Validation test is a generic framework which can be customized to measure latency response
between packets. It will measure and compute the min, max, and average latency between packets of
interest. In addition, it has a threshold value, vLatencyThreshold, defined in the Idle state that can be used
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to set a Pass/Fail criteria on the measured latency. It looks for packets in either direction but can be
modified to look only in one direction by using Metadata Validators. This framework was used to create
the Command Response and DataIn Packet latency tests.
Latency Command Response
This test measures the latency between a Command transaction code and a Response transaction code.
It looks for packets in both directions. The vLatencyThreshold variable in the Idle state can be modified to
set a Pass/Fail criteria. The resulting measurement value is in pSec.
Latency DataIn Packet
This test measures the latency between a Read Command and the DATAIN response. It looks for packets
in both directions. The vLatencyThreshold variable in the Idle state can be modified to set a Pass / Fail
criteria. The resulting measurement value is in pSec.
READ(10)
This test will check for the correct response to READ(10) / WRITE(10) commands from the tester to the
DUT. It looks for errors and verifies the correct number of DATA IN / DATA OUT packets.
Transaction Response
This test verifies all UFS commands sent by the tester have an appropriate response. It returns the number
of commands it finds.
WRITE)10)
This test will check for the correct response to READ(10) / WRITE(10) commands from the tester to the
DUT. It looks for errors and verifies the correct number of DATA IN / DATA OUT packets.

UniPro Debug Tests
UniPro Stimulus
FrameSeqNumNAC
This stimulus test generates data frames with an invalid Frame Sequence Number. It tests the DUTs ability
to respond correctly to invalid Frame Sequence Numbers.
Generate Eye Monitor Traffic
This stimulus test can be used to generate suitable traffic for building eye patterns using the Eye Monitor
under Tools → Eye Monitor
HS-Gx-RateX_Terminated (multiple tests)
HS-Gx-RateX_Unterminated (multiple tests)
PWM-Gx (multiple tests)
The above three stimulus test groups test the ability to send and receive one data packet at the specified
settings.
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TTCErr
Type4Err
Type7Err
TypeAFCErr
TypeEOFEvenErr
TypeEOFOddErr
TypeNACErr
The above seven Err stimulus tests generate the type of error implied in their name. They are useful for
verifying the DUT response to error conditions.

UniPro Trace Validation
AFC Sequence Number Order
This test case verifies that AFC sequence numbers are in order. It accounts for Hibernate and AFC frames
with errors.
AFC with CReq Set
This test verifies that an AFC with CReq set to 0 is sent in response to an AFC with the CReq bit set.
Check for Packet Errors
Checks entire trace for any UniPro packet errors.
CheckCredits
This test tracks the number of credits sent between the tester and DUT and reports errors if there are too
many credits available or too many bad data frames
CountMessages
This trace validation counts the number of data frames seen both up and down and reports that number.
Data Frame TC0 Sequence Numbers
This test tracks the sequence numbers of the data frames and checks for proper replay of NAC’d data
frames.
IO Throughput
This trace validation calculates the instantaneous and average Data Frame throughput from and to the
DUT. Clicking on an IO Throughput message (Rule) in the TV Results window will move the cursor to the
Data Frame packet that is the subject of that throughput measurement.
Link Startup Sequence
This test verifies proper progression through the seven phases of link startup, in both directions.
NAC Transmission Disabled
This test verifies that NAC transmission is disabled until the DL Layer receives one Data or Control frame
without any error.
PACP_GET_req
This test verifies that all get requests are acknowledged with a PACP_GET_cnf.
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PACP_SET_req
This test verifies that all set requests with the cnf bit set are acknowledged with a PACP_SET_cnf.
PowerModeChange
This test verifies that a PACP_PWR_req power mode change request is properly handled.
Verify Control Frames
This test verifies all of the fields in a control frame and checks for any error.
Verify Data Frames
This test verifies all of the fields in a data frame and checks for any error.
Verify NAC Transmission
This test looks for bad packets and checks for a corresponding NAC. It also looks for unexpected NACs.
Verify Outstanding Frames
This test verifies that there is no more than 16 outstanding data frames that are unacknowledged.

Appendix F: Steaming Capture
If Streaming is selected as the Capture Type in Capture Options in the Instrument Configuration tab from
Menu→Settings the instrument will write the captured trace to the controller PC’s SSD drive.
As a trace is captured it is buffered through the instrument memory (8GB) to the controller PC’s system
RAM (configurable, with default value of 4x1GB=4GB) and then saved to the SSD disk. The application
software will DMA data from the instrument memory to System RAM over the thunderbolt cable; with a
x4 Thunderbolt connection and compliant cable the transfer speeds should be ~2.4GB/s. In parallel the
application moves data from the System RAM to disk. The transfer rate from System Ram to disk is
dependent on system and the disk performance; with the best NVMe disks speeds of ~2.5GB/s are typical.
Streaming Buffer Usage in the Instrument Status window displays a graphical representation of the
amount of the instrument’s embedded memory and the controller PC’s system RAM that is being used as
a buffer as the trace is being written to the Streaming File on disk. On a controller PC with a slower SSD
write speed, the system RAM will fill up first, then the instrument's buffer. Once the analyzer capture has
stopped the Streaming Buffer Usage will gradually decrease down to zero as all data is written from the
buffers to the disk, and Streaming File Usage will stop incrementing and show the final trace size.
Instrument Configuration→Streaming Performance Test can be used to characterize the system. This
reports the achievable DMA bandwidth instrument to System RAM and from System RAM to disk. If the
system does not meet the needed performance the System RAM buffer can be increased in Streaming
Settings in the Settings→Advanced Settings tab. The max size of the System RAM buffer is only limited by
the amount of RAM on the system; we recommend leaving at least 16GB of RAM for the application SW
and other programs to use, so on 16GB we recommend using the default values of 4GB, on a 32GB system
you can use up to 16GB.
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Appendix 1: Hardware Specifications
Product specifications are subject to change without notice.

Falcon G300B/G400B series, Raptor M series
Falcon G400 series, Falcon G300 series (shipped after 1/22/2018)
Analyzer
M-PHY Type-I
Speeds:
High-Speed (HS) Gear1, Gear2, Gear3 A/B, and Gear 4 A/B modes
Low-speed Pulse-width Modulation (PWM) Gear1 to Gear4 in Type-I LS implementation
Link Width: x1 and x2
Trace capture memory depth: 8 GB
Probing:
Falcon G300B/G350B/G400B/G450B, Raptor M300/M400: SMP, solder-down
Falcon G300/G350/G400/G450: SMA, solder-down
Exerciser
M-PHY Type-I
Speeds:
High-Speed (HS) Gear1, Gear2, Gear3 A/B, and Gear 4 A/B modes
Low-speed Pulse-width Modulation (PWM) Gear1 to Gear4 in Type-I LS implementation
Link Width: x1 and x2
Trace capture memory depth: 8 GB, shared between exerciser and analyzer
Probing:
Falcon G300B/G350B/G400B/G450B, Raptor M300/M400: SMP
Falcon G300/G350/G400/G450: SMA
Advanced Trigger
States: 4 N way branching, Trigger In, Trigger Out, Go To State
Packet Matchers: 5 per direction (8 Symbol Matchers each).
Additional State/FLR/SKP matcher: 2 per direction
Counters: 2
Compare Actions: < (Less Than), == (Equal), > (Greater Than), >= (Greater Than OR Equal)
Modify Actions: Hold (No Change), Count + 1 (Increment), Count - 1 (Decrement)
Only one Compare Action per Counter can be defined in a trigger. That one Compare Action is
available in all states. You can't program "Counter1 < 5" in one state and then "Counter1 > 5" in
another state. If you program "Counter1 < 5" in one state then that is the only Compare Action
available for Counter1 in any state of the trigger. Either or both counters can be incremented or
decremented in each state.
DUT Requirements to sync analyzer to a UniPro link
Attribute
Spec
TxHsG1SyncLength (0x1552)
256 Symbols, 0x48 Capability value
TxHsG2SyncLength (0x1555)
256 Symbols, 0x48 Capability value
TxHsG3SyncLength (0x1556)
256 Symbols, 0x48 Capability value
TxHsG4SyncLength (0x15D0)
256 Symbols, 0x48 Capability value

Typical
64 Symbols, 0x46 Capability value
64 Symbols, 0x46 Capability value
64 Symbols, 0x46 Capability value
64 Symbols, 0x46 Capability value
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TxHsG1PrepareLength(0x1553)
TxHsG2PrepareLength(0x1554)
TxHsG3PrepareLength(0x1557)
TxHsG4PrepareLength(0x15D1)
RxLsPrepareLength
RxPwmBurstClosureLength
To sync to existing link

0xA Capability value
0xA Capability value
0xA Capability value
0xA Capability value
0xA Capability value
0x1F Capability value
one Start of Burst

0x3 Capability value
0x3 Capability value
0x3 Capability value
0x3 Capability value
0x1 Capability value
0x1 Capability value
one Start of Burst

The typical settings assume configuration with 50/50 splitter and recommended cables. Actual
performance may vary depending on the probing and the signal integrity of the DUT.
DUT Requirements to establish a UniPro link with the Falcon exerciser
The device must execute a UniPro 1.61 or 1.8 compliant Link Startup Sequence.

Falcon G300 series (shipped before 1/22/2018)
Analyzer
M-PHY Type-I
Speeds:
High-Speed (HS) Gear1, Gear2, and Gear3 A/B modes
Low-speed Pulse-width Modulation (PWM) Gear1 to Gear4 in Type-I LS implementation
Link Width: x1 and x2
Trace capture memory depth: 8 GB
Probing: SMA and solder-down available
Exerciser
M-PHY Type-I
Speeds:
High-Speed (HS) Gear1, Gear2, and Gear3 A/B modes
Low-speed Pulse-width Modulation (PWM) Gear1 to Gear4 in Type-I LS implementation
Link Width: x1 and x2
Trace capture memory depth: 8 GB, shared between exerciser and analyzer
Probing: SMA required for exerciser functionality
Advanced Trigger
States: 4 N way branching, Trigger In, Trigger Out, Go To State
Packet Matchers: 5 per direction (8 Symbol Matchers each).
Additional State/FLR/SKP matcher: 2 per direction
Counters: 2
Compare Actions: < (Less Than), == (Equal), > (Greater Than), >= (Greater Than OR Equal)
Modify Actions: Hold (No Change), Count + 1 (Increment), Count - 1 (Decrement)
Only one Compare Action per Counter can be defined in a trigger. That one Compare Action is
available in all states. You can't program "Counter1 < 5" in one state and then "Counter1 > 5" in
another state. If you program "Counter1 < 5" in one state then that is the only Compare Action
available for Counter1 in any state of the trigger. Either or both counters can be incremented or
decremented in each state.

P a g e |6

DUT Requirements to sync analyzer to a UniPro link
Attribute
Typical
TxHsG1SyncLength (0x1552)
16 symbols, 0x44 Capability value
TxHsG2SyncLength (0x1555)
16 symbols, 0x44 Capability value
TxHsG3SyncLength (0x1556)
16 symbols, 0x44 Capability value
TxHsG1PrepareLength(0x1553)
0xb capability value
TxHsG2PrepareLength(0x1554)
0xb capability value
TxHsG3PrepareLength(0x1557)
0xb Capability value
RxLsPrepareLength
0x8 Capability value
RxPwmBurstClosureLength
0x1f Capability value
To sync to existing link
one Start of Burst
Typical settings assume configuration with 50/50 splitter and recommended cables. Actual performance
may vary depending on the probing and the signal integrity of the DUT.
DUT Requirements to establish a UniPro link with the Falcon exerciser
The device must execute a UniPro 1.61 compliant Link Startup Sequence.

I/O Signals and Voltage Outputs - Falcon G300B/400B series, Raptor M series
UFS reference clock output: 19.2, 26, 38.4 and 52 MHz at 1.2V
UFS_Reset_N or RST: 1.2V output ± 0.3V
JESD220x requires CLK and RST voltage of 0.65*VCCQ - VCCQ+1.3. This is 0.715-1.6V min and max
VCCQ and 0.78-1.5V typical VCCQ. The output voltage changes depending on the load impedance
of the DUT; open circuit voltage is 1.3V and at 50Ω a voltage of 0.90V is supported.
Trigger in to the analyzer: 1.8V ±0.3V required.
Trigger out from the analyzer: 1.8V ±0.3V generated.
Front panel probe power ±4V

I/O Signals and Voltage Outputs - Falcon G300/400 series
The UFS reference clock output:19.2, 26, 38.4 and 52 MHz at 1.8V.
The UFS_Reset_N or RST: 1.8V output.
Trigger in to the analyzer: 1.8V ±0.3V required.
Trigger out from the analyzer: 1.8V ±0.3V generated.

Physical Characteristics
Falcon G300B/400B series, Raptor M series
Dimensions
Weight
Package Dimensions
Package Weight

12.7” x 2.7” x 9.9”, 32.4cm x 6.9cm x 25.0cm
Bumper adds 0.21”, or 5mm to the height and 0.28” or 7mm to the width.
5.9lbs, 2.7kg
18" x 18" x 11", 45.72cm x 45.72cm x 27.94 cm
12.0lbs, 5.4kg

Falcon G300/G400 series
Dimensions
Weight
Package Dimensions
Package Weight

13.6” x 3.0” x 12.12”, 34.54cm x 7.62cm x30.78cm
10.2lbs, 4.6kg
18" x 18" x 11", 45.72cm x 45.72cm x 27.94cm
16.3lbs, 7.4kg
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Operating Conditions
Falcon, Falcon B and Raptor are suitable for use in dry indoor lab locations not exceeding 35°C, and are to
be installed in accordance with the all local and national codes. They are not intended for use in hazardous
locations.

Safety, Compliance and Environmental Information
Conforms to UL STD 60950-1
Certified to CSA STD C22.2 # 60950-1
ETL Control Number: 5009155

Complies with IEC 60950-1:2005 (Second Edition) + Am 1:2009 + Am 2:2013
Manufacturer’s Declaration of Conformity to European Directive 2014/35/EU (Low
Voltage Directive)
Compliant with
CISPR 24:2015 Issue:2015 Ed:2.1 Information technology equipment - Immunity
characteristics - Limits and methods of measurement
CISPR 32 2015 COR 1 2016 Electromagnetic compatibility of multimedia equipment Emission requirements
EN 55024:2010 Information technology equipment - Immunity characteristics - Limits and
methods of measurement
EN 55032:2012 Electromagnetic compatibility of multimedia equipment - Emission
requirements
EN 61000-3-2:2014 Electromagnetic compatibility (EMC) - Part 3-2: Limits - Limits for
harmonic current emissions (equipment input current ≤ 16 A per phase)
EN 61000-3-3:2017 Electromagnetic compatibility (EMC) - Part 3-3: Limits - Limitation of
voltage changes, voltage fluctuations and flicker in public low-voltage supply systems, for
equipment with rated current &le; 16 A per phase and not subject to Conditional
Connection
IEC 61000-3-2(Ed:4.0): 2014-05, EN 61000-3-2: 2014-08 Electromagnetic compatibility
(EMC) - Part 3-2: Limits - Limits For Harmonic Current Emissions (Equipment Input Current
<= 16 A Per Phase)
IEC 61000-3-3 Ed. 3.1 b:2017 Electromagnetic compatibility (EMC) - Part 3-3: Limits Limitation of voltage changes, voltage fluctuations and flicker in public low-voltage supply
systems, for equipment with rated current &le; 16 A per phase and not subject to
Conditional Connection
FCC 47CFR 15: 2016 Telecommunication, Radio Frequency Devices
ICES-003: 2016 Issue 6, Information Technology Equipment (Including Digital Apparatus)
— Limits and Methods of Measurement
Compliant with the European Union directive 2002/95/EC and 2011/65/EU on the
Restriction of the use of certain hazardous substances in electrical and electronic
equipment and components (RoHS).
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Export Control Classification Number (ECCN) and Schedule-B Harmonization Code
No. 3B992 b.4.b.1, No License Required
US Export Schedule-B harmonization code: 9030.89.0100
Country of Manufacture: USA
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Appendix 2: System Requirements
Power requirements – external power supply
• EDAC Power Electronics Co., Ltd model EA1068
• Universal AC input 100 to 240V AC
• Output: DC +12V/6A
• Frequency: 50 to 60Hz
• Safety: UL/CUL, TUV, CB, FCC, CCC, CE, PSE, KC Mark
• Meets RoHS and WEEE
Host PC requirements
Basic configuration:
• Intel® Core™ i7 or i9 processor or equivalent.
• 32 GB RAM recommended, 16 GB minimum.
• NVMe solid state drive with 500GB free space recommended, 256GB minimum free space.
• Thunderbolt 3 enabled type-c connector required.
To take full advantage of streaming capture with v2.0.0 and later FW/SW we recommend:
• The fastest processor available, e.g. Intel i9-8950HK Processor (4.8GHz turbo)
• 64GB of RAM recommended, 32GB minimum
• 1TB NMVe SSD with Sustained Write Bandwidth of 2.5GB/s recommended, 2.1GB/s minimum
• Thunderbolt 3 enabled type-c connector required.
Software requirements
• Windows 10 64-bit operating system
• Microsoft SQL Server 2014 or later
• Microsoft Visual Studio 2015 Community or Professional editions
or
Microsoft Visual Studio 2015 Isolated Shell
• Protocol Insight application software and firmware version 1.0.4872 or later.
Note: v1.4.4.6327 or later software and firmware is required to support the Falcon G400 series.

P a g e | 10

© Protocol Insight 2016, 2017, 2018, 2019, 2020

Specifications and descriptions in this document
are subject to change without notice.
© Protocol Insight, LLC 2016, 2017, 2018, 2019, 2020
Revision 2.2 January 31, 2020

